Difference between revisions of "Bitbake World Status Zeus"

From Openembedded.org
Jump to: navigation, search
 
Line 19: Line 19:
 
|-
 
|-
 
||2019-09-08 ||3 ||3 ||6 ||3 ||17 ||0 ||0 ||0 ||1 ||0 ||56 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||
 
||2019-09-08 ||3 ||3 ||6 ||3 ||17 ||0 ||0 ||0 ||1 ||0 ||56 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||
 +
|-
 +
||2019-09-13 ||0 ||0 ||2 ||0 ||17 ||0 ||0 ||0 ||0 ||0 ||56 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||0 ||
 
|}
 
|}
 +
== Failed tasks 2019-09-13 ==
  
 +
INFO: jenkins-job.sh-1.8.46 Complete log available at http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.report.20190913_093027.log
 +
 +
=== common (0) ===
 +
 +
=== common-x86 (0) ===
 +
 +
=== qemuarm (0) ===
 +
 +
=== qemuarm64 (0) ===
 +
 +
=== qemux86 (2) ===
 +
    * sources/meta-openembedded/meta-oe/recipes-test/evtest/evtest_1.34.bb:do_compile
 +
    * sources/meta-ti/recipes-devtools/ion/libion_git.bb:do_compile
 +
 +
=== qemux86_64 (0) ===
 +
 +
=== Number of failed tasks (2) ===
 +
{| class=wikitable
 +
|-
 +
|| qemuarm || 0 || http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemuarm.20190913_015726.log/ ||
 +
|-
 +
|| qemuarm64 || 0 || http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemuarm64.20190913_023646.log/ ||
 +
|-
 +
|| qemux86 || 2 || http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemux86.20190913_022241.log/ ||
 +
|-
 +
|| qemux86_64 || 0 || http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemux86-64.20190913_030022.log/ ||
 +
|}
 +
 +
=== PNBLACKLISTs (8) ===
 +
 +
=== QA issues (56) ===
 +
{| class=wikitable
 +
!| Count ||Issue
 +
|-
 +
||0 ||already-stripped
 +
|-
 +
||0 ||build-deps
 +
|-
 +
||0 ||compile-host-path
 +
|-
 +
||0 ||file-rdeps
 +
|-
 +
||0 ||host-user-contaminated
 +
|-
 +
||0 ||installed-vs-shipped
 +
|-
 +
||0 ||invalid-pkgconfig
 +
|-
 +
||0 ||ldflags
 +
|-
 +
||0 ||libdir
 +
|-
 +
||0 ||pkgname
 +
|-
 +
||0 ||qa_pseudo
 +
|-
 +
||0 ||symlink-to-sysroot
 +
|-
 +
||0 ||textrel
 +
|-
 +
||0 ||unknown-configure-option
 +
|-
 +
||56 ||version-going-backwards
 +
|}
 +
 +
 +
 +
=== Incorrect PACKAGE_ARCH or sstate signatures (17) ===
 +
 +
Complete log: http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.signatures.20190913_031105.log/
 +
    * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver
 +
 +
    * ERROR: 2 errors found in signatures.qemux86.do_package_write_ipk.sigdata.log
 +
    * ERROR: 2 errors found in signatures.qemuarm.do_configure.sigdata.log
 +
    * ERROR: 10 errors found in signatures.qemuarm.do_populate_sysroot.sigdata.log
 +
    * ERROR: 3 errors found in signatures.qemuarm.do_package_write_ipk.sigdata.log
 +
 +
    * ERROR: runit different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
 +
    * ERROR: xscreensaver different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
 +
    * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemux86.do_package_write_ipk.sigdata.log
 +
    * ERROR: atmel-qt-demo-init different signature for task do_configure.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libxml-filter-buffertext-perl-native different signature for task do_configure.sigdata between qemux86copy and qemuarm
 +
    * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemuarm.do_configure.sigdata.log
 +
    * ERROR: atmel-qt-demo-init different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libcrypt-openssl-guess-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libextutils-config-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libextutils-helpers-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libextutils-installpaths-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libmodule-build-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: liburi-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libxml-filter-buffertext-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libxml-sax-base-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: libxml-sax-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
 +
    * ERROR: 10 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemuarm.do_populate_sysroot.sigdata.log
 +
    * ERROR: 96boards-tools different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
 +
    * ERROR: atmel-qt-demo-init different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
 +
    * ERROR: phpmyadmin different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
 +
    * ERROR: 3 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemuarm.do_package_write_ipk.sigdata.log
 +
    * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver
 +
 +
 +
PNBLACKLISTs:
 +
sources/meta-96boards:
 +
sources/meta-atmel:
 +
sources/meta-browser:
 +
sources/meta-clang:
 +
sources/meta-freescale:
 +
sources/meta-freescale-3rdparty:
 +
sources/meta-intel:
 +
sources/meta-odroid:
 +
sources/meta-openembedded:
 +
meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb:PNBLACKLIST[netkit-rusers] = "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory"
 +
meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb:PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+"
 +
meta-oe/recipes-dbs/mongodb/mongodb_git.bb:PNBLACKLIST[mongodb] = "Since bbclass scons convert to python3, build mongodb failed"
 +
meta-oe/recipes-extended/socketcan/can-isotp_git.bb:PNBLACKLIST[can-isotp] = "Kernel module Needs forward porting to kernel 5.2+"
 +
meta-oe/recipes-extended/sysdig/sysdig_git.bb:PNBLACKLIST[sysdig] = "configure: error: in 'TOPDIR/build/tmpfs/work/core2-64-yoe-linux/sysdig/0.26.4-r0/build/c-ares-prefix/src/c-ares'"
 +
meta-oe/recipes-kernel/bpftool/bpftool.bb:PNBLACKLIST[bpftool] = "Needs forward porting to kernel 5.2+"
 +
meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb:PNBLACKLIST[vboxguestdrivers] = "Needs forward porting to kernel 5.2+"
 +
sources/meta-qcom:
 +
sources/meta-qt5:
 +
sources/meta-raspberrypi:
 +
sources/meta-riscv:
 +
sources/meta-rust:
 +
sources/meta-ti:
 +
sources/meta-variscite-fslc:
 +
sources/meta-yoe:
 +
sources/openembedded-core:
 +
meta/lib/oeqa/selftest/cases/imagefeatures.py:PNBLACKLIST[busybox] = "Don't build this"
 +
PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds"
 +
PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much"
 +
PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much"
 +
PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much"
 +
PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much"
 +
PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/"
 +
PNBLACKLIST[smartrefrigerator] = "Needs porting to QT > 5.6"
 +
PNBLACKLIST[qmlbrowser] = "Needs porting to QT > 5.6"
 +
PNBLACKLIST[minehunt] = "Needs porting to QT > 5.6"
 +
PNBLACKLIST[homeautomation] = "Needs porting to QT > 5.6"
 +
PNBLACKLIST[samegame] = "Needs porting to QT > 5.6"
 +
PNBLACKLIST[applicationlauncher] = "Needs porting to QT > 5.6"
 +
PNBLACKLIST[evolution-data-server] = "Qemu usermode hangs forever on abaco/kwaj builders when doing g-ir-scanner-qemuwrapper"
 +
 +
 +
QA issues by type:
 +
count: 0 issue: already-stripped
 +
 +
 +
count: 0 issue: libdir
 +
 +
 +
count: 0 issue: textrel
 +
 +
 +
count: 0 issue: build-deps
 +
 +
 +
count: 0 issue: file-rdeps
 +
 +
 +
count: 56 issue: version-going-backwards
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards]
 +
atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release-dbg went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release-dev went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release-doc went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release-locale went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release-src went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release-staticdev went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
os-release-1.0: Package version for package os-release went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards]
 +
packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dbg went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards]
 +
packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dev went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards]
 +
packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-ptest went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards]
 +
packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-src went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards]
 +
packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards]
 +
packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dbg went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards]
 +
packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dev went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards]
 +
packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-ptest went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards]
 +
packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-src went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards]
 +
packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-src went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]
 +
 +
 +
count: 0 issue: host-user-contaminated
 +
 +
 +
count: 0 issue: installed-vs-shipped
 +
 +
 +
count: 0 issue: unknown-configure-option
 +
 +
 +
count: 0 issue: symlink-to-sysroot
 +
 +
 +
count: 0 issue: invalid-pkgconfig
 +
 +
 +
count: 0 issue: pkgname
 +
 +
 +
count: 0 issue: ldflags
 +
 +
 +
count: 0 issue: compile-host-path
 +
 +
 +
count: 0 issue: qa_pseudo
 
== Failed tasks 2019-09-08 ==
 
== Failed tasks 2019-09-08 ==
  

Latest revision as of 16:41, 13 September 2019

The setup and jenkins scripts used to generate these reports are described here: http://www.openembedded.org/wiki/Bitbake_World_Status_Setup

Results for other Yocto releases are in: http://www.openembedded.org/wiki/Bitbake_World_Status

http://www.openembedded.org/wiki/Bitbake_World_Status

Number of issues - stats

Date Failed tasks Signatures QA Comment
qemuarm qemuarm64 qemux86 qemux86_64 all already-stripped libdir textrel build-deps file-rdeps version-going-backwards host-user-contaminated installed-vs-shipped unknown-configure-option symlink-to-sysroot invalid-pkgconfig pkgname ldflags compile-host-path qa_pseudo
2019-06-19 12 13 11 3 0 0 0 1 0 0 0 1 0 0 0 0 0 0 0 0
2019-08-11 9 9 8 11 0 0 0 0 1 0 56 1 0 0 0 0 0 0 0 0
2019-08-18 7 9 8 10 17 0 0 0 1 0 56 1 0 0 0 0 0 0 0 0
2019-09-08 3 3 6 3 17 0 0 0 1 0 56 0 0 0 0 0 0 0 0 0
2019-09-13 0 0 2 0 17 0 0 0 0 0 56 0 0 0 0 0 0 0 0 0

Failed tasks 2019-09-13

INFO: jenkins-job.sh-1.8.46 Complete log available at http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.report.20190913_093027.log

common (0)

common-x86 (0)

qemuarm (0)

qemuarm64 (0)

qemux86 (2)

   * sources/meta-openembedded/meta-oe/recipes-test/evtest/evtest_1.34.bb:do_compile
   * sources/meta-ti/recipes-devtools/ion/libion_git.bb:do_compile

qemux86_64 (0)

Number of failed tasks (2)

qemuarm 0 http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemuarm.20190913_015726.log/
qemuarm64 0 http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemuarm64.20190913_023646.log/
qemux86 2 http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemux86.20190913_022241.log/
qemux86_64 0 http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.world.qemux86-64.20190913_030022.log/

PNBLACKLISTs (8)

QA issues (56)

Count Issue
0 already-stripped
0 build-deps
0 compile-host-path
0 file-rdeps
0 host-user-contaminated
0 installed-vs-shipped
0 invalid-pkgconfig
0 ldflags
0 libdir
0 pkgname
0 qa_pseudo
0 symlink-to-sysroot
0 textrel
0 unknown-configure-option
56 version-going-backwards


Incorrect PACKAGE_ARCH or sstate signatures (17)

Complete log: http://logs.nslu2-linux.org/buildlogs/oe/world/zeus/log.signatures.20190913_031105.log/

   * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver
   * ERROR: 2 errors found in signatures.qemux86.do_package_write_ipk.sigdata.log
   * ERROR: 2 errors found in signatures.qemuarm.do_configure.sigdata.log
   * ERROR: 10 errors found in signatures.qemuarm.do_populate_sysroot.sigdata.log
   * ERROR: 3 errors found in signatures.qemuarm.do_package_write_ipk.sigdata.log
   * ERROR: runit different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
   * ERROR: xscreensaver different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
   * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemux86.do_package_write_ipk.sigdata.log
   * ERROR: atmel-qt-demo-init different signature for task do_configure.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-filter-buffertext-perl-native different signature for task do_configure.sigdata between qemux86copy and qemuarm
   * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemuarm.do_configure.sigdata.log
   * ERROR: atmel-qt-demo-init different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libcrypt-openssl-guess-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-config-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-helpers-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-installpaths-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libmodule-build-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: liburi-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-filter-buffertext-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-sax-base-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-sax-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: 10 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemuarm.do_populate_sysroot.sigdata.log
   * ERROR: 96boards-tools different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: atmel-qt-demo-init different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: phpmyadmin different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: 3 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1568369466/signatures.qemuarm.do_package_write_ipk.sigdata.log
   * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver


PNBLACKLISTs: sources/meta-96boards: sources/meta-atmel: sources/meta-browser: sources/meta-clang: sources/meta-freescale: sources/meta-freescale-3rdparty: sources/meta-intel: sources/meta-odroid: sources/meta-openembedded: meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb:PNBLACKLIST[netkit-rusers] = "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory" meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb:PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+" meta-oe/recipes-dbs/mongodb/mongodb_git.bb:PNBLACKLIST[mongodb] = "Since bbclass scons convert to python3, build mongodb failed" meta-oe/recipes-extended/socketcan/can-isotp_git.bb:PNBLACKLIST[can-isotp] = "Kernel module Needs forward porting to kernel 5.2+" meta-oe/recipes-extended/sysdig/sysdig_git.bb:PNBLACKLIST[sysdig] = "configure: error: in 'TOPDIR/build/tmpfs/work/core2-64-yoe-linux/sysdig/0.26.4-r0/build/c-ares-prefix/src/c-ares'" meta-oe/recipes-kernel/bpftool/bpftool.bb:PNBLACKLIST[bpftool] = "Needs forward porting to kernel 5.2+" meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb:PNBLACKLIST[vboxguestdrivers] = "Needs forward porting to kernel 5.2+" sources/meta-qcom: sources/meta-qt5: sources/meta-raspberrypi: sources/meta-riscv: sources/meta-rust: sources/meta-ti: sources/meta-variscite-fslc: sources/meta-yoe: sources/openembedded-core: meta/lib/oeqa/selftest/cases/imagefeatures.py:PNBLACKLIST[busybox] = "Don't build this" PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds" PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/" PNBLACKLIST[smartrefrigerator] = "Needs porting to QT > 5.6" PNBLACKLIST[qmlbrowser] = "Needs porting to QT > 5.6" PNBLACKLIST[minehunt] = "Needs porting to QT > 5.6" PNBLACKLIST[homeautomation] = "Needs porting to QT > 5.6" PNBLACKLIST[samegame] = "Needs porting to QT > 5.6" PNBLACKLIST[applicationlauncher] = "Needs porting to QT > 5.6" PNBLACKLIST[evolution-data-server] = "Qemu usermode hangs forever on abaco/kwaj builders when doing g-ir-scanner-qemuwrapper"


QA issues by type: count: 0 issue: already-stripped


count: 0 issue: libdir


count: 0 issue: textrel


count: 0 issue: build-deps


count: 0 issue: file-rdeps


count: 56 issue: version-going-backwards atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.231 to 0:1.1-r2.230) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.236 to 0:1.1-r2.235) [version-going-backwards] os-release-1.0: Package version for package os-release-dbg went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] os-release-1.0: Package version for package os-release-dev went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] os-release-1.0: Package version for package os-release-doc went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] os-release-1.0: Package version for package os-release-locale went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] os-release-1.0: Package version for package os-release-src went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] os-release-1.0: Package version for package os-release-staticdev went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] os-release-1.0: Package version for package os-release went backwards which would break package feeds from (0:1.0-r0.234 to 0:1.0-r0.233) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dbg went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dev went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-ptest went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-src went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target went backwards which would break package feeds from (0:1.0-r8.286 to 0:1.0-r8.285) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dbg went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dev went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-ptest went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-src went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug went backwards which would break package feeds from (0:1.0-r3.284 to 0:1.0-r3.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dbg went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dev went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-ptest went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-src went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted went backwards which would break package feeds from (0:1.0-r13.284 to 0:1.0-r13.283) [version-going-backwards]


count: 0 issue: host-user-contaminated


count: 0 issue: installed-vs-shipped


count: 0 issue: unknown-configure-option


count: 0 issue: symlink-to-sysroot


count: 0 issue: invalid-pkgconfig


count: 0 issue: pkgname


count: 0 issue: ldflags


count: 0 issue: compile-host-path


count: 0 issue: qa_pseudo

Failed tasks 2019-09-08

INFO: jenkins-job.sh-1.8.46 Complete log available at http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.report.20190908_140140.log

common (3)

   * sources/meta-openembedded/meta-gnome/recipes-extended/gparted/gparted_0.33.0.bb:do_package_qa
   * sources/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb:do_compile
   * sources/openembedded-core/meta/recipes-graphics/wayland/weston-init.bb:do_install

common-x86 (0)

qemuarm (0)

qemuarm64 (0)

qemux86 (3)

   * sources/meta-openembedded/meta-oe/recipes-core/safec/safec_3.4.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/breakpad/breakpad_git.bb:do_compile

qemux86_64 (0)

Number of failed tasks (15)

qemuarm 3 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm.20190908_065258.log/
qemuarm64 3 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm64.20190908_073153.log/
qemux86 6 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86.20190908_050302.log/
qemux86_64 3 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86-64.20190908_054120.log/

PNBLACKLISTs (10)

QA issues (57)

Count Issue
0 already-stripped
0 compile-host-path
0 file-rdeps
0 host-user-contaminated
0 installed-vs-shipped
0 invalid-pkgconfig
0 ldflags
0 libdir
0 pkgname
0 qa_pseudo
0 symlink-to-sysroot
0 textrel
0 unknown-configure-option
1 build-deps
56 version-going-backwards


Incorrect PACKAGE_ARCH or sstate signatures (17)

Complete log: http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.signatures.20190908_080636.log/

   * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver
   * ERROR: 2 errors found in signatures.qemux86.do_package_write_ipk.sigdata.log
   * ERROR: 2 errors found in signatures.qemuarm.do_configure.sigdata.log
   * ERROR: 10 errors found in signatures.qemuarm.do_populate_sysroot.sigdata.log
   * ERROR: 3 errors found in signatures.qemuarm.do_package_write_ipk.sigdata.log
   * ERROR: runit different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
   * ERROR: xscreensaver different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
   * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1567955196/signatures.qemux86.do_package_write_ipk.sigdata.log
   * ERROR: atmel-qt-demo-init different signature for task do_configure.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-filter-buffertext-perl-native different signature for task do_configure.sigdata between qemux86copy and qemuarm
   * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1567955196/signatures.qemuarm.do_configure.sigdata.log
   * ERROR: atmel-qt-demo-init different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libcrypt-openssl-guess-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-config-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-helpers-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-installpaths-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libmodule-build-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: liburi-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-filter-buffertext-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-sax-base-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-sax-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: 10 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1567955196/signatures.qemuarm.do_populate_sysroot.sigdata.log
   * ERROR: 96boards-tools different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: atmel-qt-demo-init different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: phpmyadmin different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: 3 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1567955196/signatures.qemuarm.do_package_write_ipk.sigdata.log
   * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver


PNBLACKLISTs: sources/meta-96boards: sources/meta-atmel: sources/meta-browser: sources/meta-clang: sources/meta-freescale: sources/meta-freescale-3rdparty: sources/meta-intel: sources/meta-odroid: sources/meta-openembedded: meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb:PNBLACKLIST[netkit-rusers] = "Fails to build rup.c:51:10: fatal error: rstat.h: No such file or directory" meta-networking/recipes-support/drbd/drbd_9.0.19-1.bb:PNBLACKLIST[drbd] = "Kernel module Needs forward porting to kernel 5.2+" meta-oe/recipes-dbs/mongodb/mongodb_git.bb:PNBLACKLIST[mongodb] = "Since bbclass scons convert to python3, build mongodb failed" meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb:PNBLACKLIST[librcf] = " error: invalid use of incomplete type 'RCF::AsioIoService {aka class boost::asio::io_service}; among others?" meta-oe/recipes-extended/socketcan/can-isotp_git.bb:PNBLACKLIST[can-isotp] = "Kernel module Needs forward porting to kernel 5.2+" meta-oe/recipes-extended/sysdig/sysdig_git.bb:PNBLACKLIST[sysdig] = "configure: error: in 'TOPDIR/build/tmpfs/work/core2-64-yoe-linux/sysdig/0.26.4-r0/build/c-ares-prefix/src/c-ares'" meta-oe/recipes-kernel/bpftool/bpftool.bb:PNBLACKLIST[bpftool] = "Needs forward porting to kernel 5.2+" meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb:PNBLACKLIST[vboxguestdrivers] = "Needs forward porting to kernel 5.2+" meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb:PNBLACKLIST[python3-cmd2] = "Nothing RPROVIDES 'python3-colorama' (but python3-cmd2_0.9.16.bb RDEPENDS on or otherwise requires it)" sources/meta-qcom: sources/meta-qt5: sources/meta-raspberrypi: sources/meta-riscv: sources/meta-rust: sources/meta-ti: sources/meta-variscite-fslc: sources/meta-yoe: sources/openembedded-core: meta/lib/oeqa/selftest/cases/imagefeatures.py:PNBLACKLIST[busybox] = "Don't build this" PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds" PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/" PNBLACKLIST[smartrefrigerator] = "Needs porting to QT > 5.6" PNBLACKLIST[qmlbrowser] = "Needs porting to QT > 5.6" PNBLACKLIST[minehunt] = "Needs porting to QT > 5.6" PNBLACKLIST[homeautomation] = "Needs porting to QT > 5.6" PNBLACKLIST[samegame] = "Needs porting to QT > 5.6" PNBLACKLIST[applicationlauncher] = "Needs porting to QT > 5.6" PNBLACKLIST[evolution-data-server] = "Qemu usermode hangs forever on abaco/kwaj builders when doing g-ir-scanner-qemuwrapper"


QA issues by type: count: 0 issue: already-stripped


count: 0 issue: libdir


count: 0 issue: textrel


count: 1 issue: build-deps gparted-0.33.0: gparted rdepends on hicolor-icon-theme, but it isn't a build dependency, missing hicolor-icon-theme in DEPENDS or PACKAGECONFIG? [build-deps]


count: 0 issue: file-rdeps


count: 56 issue: version-going-backwards atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.222 to 0:1.1-r2.221) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.228 to 0:1.1-r2.227) [version-going-backwards] os-release-1.0: Package version for package os-release-dbg went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] os-release-1.0: Package version for package os-release-dev went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] os-release-1.0: Package version for package os-release-doc went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] os-release-1.0: Package version for package os-release-locale went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] os-release-1.0: Package version for package os-release-src went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] os-release-1.0: Package version for package os-release-staticdev went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] os-release-1.0: Package version for package os-release went backwards which would break package feeds from (0:1.0-r0.226 to 0:1.0-r0.225) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dbg went backwards which would break package feeds from (0:1.0-r8.278 to 0:1.0-r8.277) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dev went backwards which would break package feeds from (0:1.0-r8.278 to 0:1.0-r8.277) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-ptest went backwards which would break package feeds from (0:1.0-r8.278 to 0:1.0-r8.277) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-src went backwards which would break package feeds from (0:1.0-r8.278 to 0:1.0-r8.277) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target went backwards which would break package feeds from (0:1.0-r8.278 to 0:1.0-r8.277) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dbg went backwards which would break package feeds from (0:1.0-r3.276 to 0:1.0-r3.275) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dev went backwards which would break package feeds from (0:1.0-r3.276 to 0:1.0-r3.275) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-ptest went backwards which would break package feeds from (0:1.0-r3.276 to 0:1.0-r3.275) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-src went backwards which would break package feeds from (0:1.0-r3.276 to 0:1.0-r3.275) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug went backwards which would break package feeds from (0:1.0-r3.276 to 0:1.0-r3.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dbg went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dbg went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dev went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-ptest went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dev went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dbg went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dev went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-ptest went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dbg went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dev went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-ptest went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dbg went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dev went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-ptest went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-ptest went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dbg went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dev went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-ptest went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-src went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted went backwards which would break package feeds from (0:1.0-r13.276 to 0:1.0-r13.275) [version-going-backwards]


count: 0 issue: host-user-contaminated


count: 0 issue: installed-vs-shipped


count: 0 issue: unknown-configure-option


count: 0 issue: symlink-to-sysroot


count: 0 issue: invalid-pkgconfig


count: 0 issue: pkgname


count: 0 issue: ldflags


count: 0 issue: compile-host-path


count: 0 issue: qa_pseudo

Failed tasks 2019-08-18

INFO: jenkins-job.sh-1.8.46 Complete log available at http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.report.20190818_084240.log

common (3)

   * sources/meta-openembedded/meta-gnome/recipes-extended/gparted/gparted_0.33.0.bb:do_package_qa
   * sources/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb:do_compile

common-x86 (1)

   * sources/meta-openembedded/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb:do_compile

qemuarm (4)

   * sources/meta-freescale/recipes-extended/dpdk/dpdk_18.11.bb:do_compile
   * sources/meta-freescale/recipes-extended/vpp-core/dpdkvpp.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-extended/libnss-nisplus/libnss-nisplus.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-kernel/bpftool/bpftool.bb:do_compile

qemuarm64 (2)

   * sources/meta-openembedded/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb:do_compile
   * sources/openembedded-core/meta/recipes-core/glibc/glibc-locale_2.30.bb:do_package_qa

qemux86 (4)

   * sources/meta-openembedded/meta-oe/recipes-core/safec/safec_3.4.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/breakpad/breakpad_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.8.bb:do_compile

qemux86_64 (1)

   * build/tmpfs/work/core2-64-yoe-linux/sysdig/0.26.1+gitAUTOINC+baf311c42c-r0/build/openssl-prefix/src/openssl/target

Number of failed tasks (34)

qemuarm 7 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm.20190817_233622.log/
qemuarm64 9 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm64.20190818_001623.log/
qemux86 8 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86.20190818_021753.log/
qemux86_64 10 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86-64.20190818_025723.log/

PNBLACKLISTs (3)

QA issues (58)

Count Issue
0 already-stripped
0 compile-host-path
0 file-rdeps
0 installed-vs-shipped
0 invalid-pkgconfig
0 ldflags
0 libdir
0 pkgname
0 qa_pseudo
0 symlink-to-sysroot
0 textrel
0 unknown-configure-option
1 build-deps
1 host-user-contaminated
56 version-going-backwards


Incorrect PACKAGE_ARCH or sstate signatures (17)

Complete log: http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.signatures.20190818_005145.log/

   * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver
   * ERROR: 2 errors found in signatures.qemux86.do_package_write_ipk.sigdata.log
   * ERROR: 2 errors found in signatures.qemuarm.do_configure.sigdata.log
   * ERROR: 10 errors found in signatures.qemuarm.do_populate_sysroot.sigdata.log
   * ERROR: 3 errors found in signatures.qemuarm.do_package_write_ipk.sigdata.log
   * ERROR: runit different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
   * ERROR: xscreensaver different signature for task do_package_write_ipk.sigdata between qemux86copy and qemux86
   * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1566114705/signatures.qemux86.do_package_write_ipk.sigdata.log
   * ERROR: atmel-qt-demo-init different signature for task do_configure.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-filter-buffertext-perl-native different signature for task do_configure.sigdata between qemux86copy and qemuarm
   * ERROR: 2 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1566114705/signatures.qemuarm.do_configure.sigdata.log
   * ERROR: atmel-qt-demo-init different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libcrypt-openssl-guess-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-config-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-helpers-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libextutils-installpaths-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libmodule-build-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: liburi-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-filter-buffertext-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-sax-base-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: libxml-sax-perl-native different signature for task do_populate_sysroot.sigdata between qemux86copy and qemuarm
   * ERROR: 10 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1566114705/signatures.qemuarm.do_populate_sysroot.sigdata.log
   * ERROR: 96boards-tools different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: atmel-qt-demo-init different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: phpmyadmin different signature for task do_package_write_ipk.sigdata between qemux86copy and qemuarm
   * ERROR: 3 errors found in /home/jenkins/oe/world/yoe/build/tmpfs/sstate-diff/1566114705/signatures.qemuarm.do_package_write_ipk.sigdata.log
   * ERROR: 17 issues were found in these recipes: 96boards-tools atmel-qt-demo-init libcrypt-openssl-guess-perl-native libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native libmodule-build-perl-native liburi-perl-native libxml-filter-buffertext-perl-native libxml-sax-base-perl-native libxml-sax-perl-native phpmyadmin runit xscreensaver


PNBLACKLISTs: sources/meta-96boards: sources/meta-atmel: sources/meta-browser: sources/meta-clang: sources/meta-freescale: sources/meta-freescale-3rdparty: sources/meta-intel: sources/meta-odroid: sources/meta-openembedded: meta-oe/recipes-dbs/mongodb/mongodb_git.bb:PNBLACKLIST[mongodb] = "Since bbclass scons convert to python3, build mongodb failed" meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb:PNBLACKLIST[librcf] = " error: invalid use of incomplete type 'RCF::AsioIoService {aka class boost::asio::io_service}; among others?" sources/meta-qcom: sources/meta-qt5: sources/meta-raspberrypi: sources/meta-riscv: sources/meta-rust: sources/meta-ti: sources/meta-variscite-fslc: sources/meta-yoe: sources/openembedded-core: meta/lib/oeqa/selftest/cases/imagefeatures.py:PNBLACKLIST[busybox] = "Don't build this" PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds" PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/" PNBLACKLIST[smartrefrigerator] = "Needs porting to QT > 5.6" PNBLACKLIST[qmlbrowser] = "Needs porting to QT > 5.6" PNBLACKLIST[minehunt] = "Needs porting to QT > 5.6" PNBLACKLIST[homeautomation] = "Needs porting to QT > 5.6" PNBLACKLIST[samegame] = "Needs porting to QT > 5.6" PNBLACKLIST[applicationlauncher] = "Needs porting to QT > 5.6"


QA issues by type: count: 0 issue: already-stripped


count: 0 issue: libdir


count: 0 issue: textrel


count: 1 issue: build-deps gparted-0.33.0: gparted rdepends on hicolor-icon-theme, but it isn't a build dependency, missing hicolor-icon-theme in DEPENDS or PACKAGECONFIG? [build-deps]


count: 0 issue: file-rdeps


count: 56 issue: version-going-backwards atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.191 to 0:1.1-r2.190) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.198 to 0:1.1-r2.197) [version-going-backwards] os-release-1.0: Package version for package os-release-dbg went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] os-release-1.0: Package version for package os-release-dev went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] os-release-1.0: Package version for package os-release-doc went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] os-release-1.0: Package version for package os-release-locale went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] os-release-1.0: Package version for package os-release-src went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] os-release-1.0: Package version for package os-release-staticdev went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] os-release-1.0: Package version for package os-release went backwards which would break package feeds from (0:1.0-r0.200 to 0:1.0-r0.199) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dbg went backwards which would break package feeds from (0:1.0-r8.252 to 0:1.0-r8.251) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dev went backwards which would break package feeds from (0:1.0-r8.252 to 0:1.0-r8.251) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-ptest went backwards which would break package feeds from (0:1.0-r8.252 to 0:1.0-r8.251) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-src went backwards which would break package feeds from (0:1.0-r8.252 to 0:1.0-r8.251) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target went backwards which would break package feeds from (0:1.0-r8.252 to 0:1.0-r8.251) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dbg went backwards which would break package feeds from (0:1.0-r3.251 to 0:1.0-r3.250) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dev went backwards which would break package feeds from (0:1.0-r3.251 to 0:1.0-r3.250) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-ptest went backwards which would break package feeds from (0:1.0-r3.251 to 0:1.0-r3.250) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-src went backwards which would break package feeds from (0:1.0-r3.251 to 0:1.0-r3.250) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug went backwards which would break package feeds from (0:1.0-r3.251 to 0:1.0-r3.250) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dbg went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dbg went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dev went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-ptest went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dev went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dbg went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dev went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-ptest went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dbg went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dev went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-ptest went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dbg went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dev went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-ptest went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-ptest went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dbg went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dev went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-ptest went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-src went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted went backwards which would break package feeds from (0:1.0-r13.252 to 0:1.0-r13.251) [version-going-backwards]


count: 1 issue: host-user-contaminated glibc-locale-2.30: glibc-locale: /usr/lib/locale/ar_EG.ISO-8859-6/LC_MEASUREMENT is owned by uid 3004, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]


count: 0 issue: installed-vs-shipped


count: 0 issue: unknown-configure-option


count: 0 issue: symlink-to-sysroot


count: 0 issue: invalid-pkgconfig


count: 0 issue: pkgname


count: 0 issue: ldflags


count: 0 issue: compile-host-path


count: 0 issue: qa_pseudo

Failed tasks 2019-08-11

INFO: jenkins-job.sh-1.8.45 Complete log available at http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.report.20190811_195557.log

common (3)

   * sources/meta-openembedded/meta-gnome/recipes-extended/gparted/gparted_0.33.0.bb:do_package_qa
   * sources/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-extended/sysdig/sysdig_git.bb:do_compile

common-x86 (1)

   * sources/meta-openembedded/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb:do_compile

qemuarm (6)

   * sources/meta-freescale/recipes-extended/dpdk/dpdk_18.11.bb:do_compile
   * sources/meta-freescale/recipes-extended/vpp-core/dpdkvpp.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-extended/libnss-nisplus/libnss-nisplus.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-kernel/bpftool/bpftool.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb:do_install
   * sources/openembedded-core/meta/recipes-devtools/python-numpy/python3-numpy_1.17.0.bb:do_compile

qemuarm64 (1)

   * sources/meta-openembedded/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb:do_compile

qemux86 (3)

   * sources/meta-openembedded/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/breakpad/breakpad_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.8.bb:do_compile

qemux86_64 (2)

   * build/tmpfs/work/core2-64-yoe-linux/sysdig/0.26.1+gitAUTOINC+baf311c42c-r0/build/openssl-prefix/src/openssl/target
   * sources/openembedded-core/meta/recipes-core/glibc/glibc-locale_2.30.bb:do_package_qa

Number of failed tasks (37)

qemuarm 9 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm.20190811_105925.log/
qemuarm64 9 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm64.20190811_133156.log/
qemux86 8 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86.20190811_145632.log/
qemux86_64 11 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86-64.20190811_172248.log/

PNBLACKLISTs (3)

QA issues (58)

Count Issue
0 already-stripped
0 compile-host-path
0 file-rdeps
0 installed-vs-shipped
0 invalid-pkgconfig
0 ldflags
0 libdir
0 pkgname
0 qa_pseudo
0 symlink-to-sysroot
0 textrel
0 unknown-configure-option
1 build-deps
1 host-user-contaminated
56 version-going-backwards


Incorrect PACKAGE_ARCH or sstate signatures (0)

Complete log: http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.signatures.20190811_160010.log/


   * ERROR: Nothing RPROVIDES 'bigbuckbunny-480p' (but /home/jenkins/oe/world/yoe/sources/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb RDEPENDS on or otherwise requires it)
   * ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
   * ERROR: no sigdata files were generated for MACHINE qemux86copy in /home/jenkins/oe/world/yoe/build/tmpfs/stamps
   * ERROR: Nothing RPROVIDES 'bigbuckbunny-1080p' (but /home/jenkins/oe/world/yoe/sources/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb RDEPENDS on or otherwise requires it)
   * ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
   * ERROR: no sigdata files were generated for MACHINE qemux86 in /home/jenkins/oe/world/yoe/build/tmpfs/stamps
   * ERROR: Nothing RPROVIDES 'bigbuckbunny-1080p' (but /home/jenkins/oe/world/yoe/sources/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb RDEPENDS on or otherwise requires it)
   * ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
   * ERROR: no sigdata files were generated for MACHINE qemuarm in /home/jenkins/oe/world/yoe/build/tmpfs/stamps


PNBLACKLISTs: sources/meta-96boards: sources/meta-atmel: sources/meta-browser: sources/meta-clang: sources/meta-freescale: sources/meta-freescale-3rdparty: sources/meta-intel: sources/meta-odroid: sources/meta-openembedded: meta-oe/recipes-dbs/mongodb/mongodb_git.bb:PNBLACKLIST[mongodb] = "Since bbclass scons convert to python3, build mongodb failed" meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb:PNBLACKLIST[librcf] = " error: invalid use of incomplete type 'RCF::AsioIoService {aka class boost::asio::io_service}; among others?" sources/meta-qcom: sources/meta-qt5: sources/meta-raspberrypi: sources/meta-riscv: sources/meta-rust: sources/meta-ti: sources/meta-variscite-fslc: sources/meta-yoe: sources/openembedded-core: meta/lib/oeqa/selftest/cases/imagefeatures.py:PNBLACKLIST[busybox] = "Don't build this" PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds" PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/" PNBLACKLIST[smartrefrigerator] = "Needs porting to QT > 5.6" PNBLACKLIST[qmlbrowser] = "Needs porting to QT > 5.6" PNBLACKLIST[minehunt] = "Needs porting to QT > 5.6" PNBLACKLIST[homeautomation] = "Needs porting to QT > 5.6" PNBLACKLIST[samegame] = "Needs porting to QT > 5.6" PNBLACKLIST[applicationlauncher] = "Needs porting to QT > 5.6"


QA issues by type: count: 0 issue: already-stripped


count: 0 issue: libdir


count: 0 issue: textrel


count: 1 issue: build-deps gparted-0.33.0: gparted rdepends on hicolor-icon-theme, but it isn't a build dependency, missing hicolor-icon-theme in DEPENDS or PACKAGECONFIG? [build-deps]


count: 0 issue: file-rdeps


count: 56 issue: version-going-backwards atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dbg went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-dev went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-doc went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-locale went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-src went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init-staticdev went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.178 to 0:1.1-r2.177) [version-going-backwards] atmel-qt-demo-init-1.1: Package version for package atmel-qt-demo-init went backwards which would break package feeds from (0:1.1-r2.187 to 0:1.1-r2.186) [version-going-backwards] os-release-1.0: Package version for package os-release-dbg went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] os-release-1.0: Package version for package os-release-dev went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] os-release-1.0: Package version for package os-release-doc went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] os-release-1.0: Package version for package os-release-locale went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] os-release-1.0: Package version for package os-release-src went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] os-release-1.0: Package version for package os-release-staticdev went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] os-release-1.0: Package version for package os-release went backwards which would break package feeds from (0:1.0-r0.190 to 0:1.0-r0.189) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dbg went backwards which would break package feeds from (0:1.0-r8.242 to 0:1.0-r8.241) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-dev went backwards which would break package feeds from (0:1.0-r8.242 to 0:1.0-r8.241) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-ptest went backwards which would break package feeds from (0:1.0-r8.242 to 0:1.0-r8.241) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target-src went backwards which would break package feeds from (0:1.0-r8.242 to 0:1.0-r8.241) [version-going-backwards] packagegroup-core-standalone-sdk-target-1.0: Package version for package packagegroup-core-standalone-sdk-target went backwards which would break package feeds from (0:1.0-r8.242 to 0:1.0-r8.241) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dbg went backwards which would break package feeds from (0:1.0-r3.241 to 0:1.0-r3.240) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-dev went backwards which would break package feeds from (0:1.0-r3.241 to 0:1.0-r3.240) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-ptest went backwards which would break package feeds from (0:1.0-r3.241 to 0:1.0-r3.240) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug-src went backwards which would break package feeds from (0:1.0-r3.241 to 0:1.0-r3.240) [version-going-backwards] packagegroup-core-tools-debug-1.0: Package version for package packagegroup-core-tools-debug went backwards which would break package feeds from (0:1.0-r3.241 to 0:1.0-r3.240) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dbg went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dbg went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-dev went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug-ptest went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-debug went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-dev went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dbg went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-dev went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended-ptest went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-extended went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dbg went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-dev went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics-ptest went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-graphics went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dbg went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-dev went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools-ptest went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-host-tools went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-ptest went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dbg went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-dev went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk-ptest went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-sdk went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted-src went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards] packagegroup-self-hosted-1.0: Package version for package packagegroup-self-hosted went backwards which would break package feeds from (0:1.0-r13.242 to 0:1.0-r13.241) [version-going-backwards]


count: 1 issue: host-user-contaminated glibc-locale-2.30: glibc-locale: /usr/lib/locale/so_SO.ISO-8859-1/LC_PAPER is owned by uid 3004, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]


count: 0 issue: installed-vs-shipped


count: 0 issue: unknown-configure-option


count: 0 issue: symlink-to-sysroot


count: 0 issue: invalid-pkgconfig


count: 0 issue: pkgname


count: 0 issue: ldflags


count: 0 issue: compile-host-path


count: 0 issue: qa_pseudo

Failed tasks 2019-06-19

INFO: jenkins-job.sh-1.8.45 Complete log available at http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.report.20190621_062638.log

common (2)

   * sources/meta-openembedded/meta-oe/recipes-devtools/openocd/openocd_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/protobuf/protobuf_3.8.0.bb:do_compile

common-x86 (0)

qemuarm (10)

   * sources/meta-browser/dynamic-layers/rust-layer/recipes-browser/firefox/firefox_60.4.0esr.bb:do_compile
   * sources/meta-browser/recipes-browser/chromium/chromium-ozone-wayland_75.0.3770.90.bb:do_compile
   * sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-qca6174_2.1.bb:do_compile
   * sources/meta-freescale/recipes-kernel/kernel-modules/kernel-module-qca9377_2.1.bb:do_compile
   * sources/meta-openembedded/meta-networking/recipes-netkit/netkit-rusers/netkit-rusers_0.17.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-kernel/bpftool/bpftool.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb:do_install
   * sources/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_compile
   * sources/meta-rust/recipes-devtools/rust/rust_1.34.2.bb:do_compile
   * sources/openembedded-core/meta/recipes-multimedia/mpeg2dec/mpeg2dec_0.5.1.bb:do_package_qa

qemuarm64 (5)

   * sources/meta-browser/recipes-browser/chromium/chromium-ozone-wayland_75.0.3770.100.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-core/safec/safec_3.4.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-dbs/mongodb/mongodb_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-kernel/kernel-selftest/kernel-selftest.bb:do_compile
   * sources/meta-qt5/recipes-qt/qt5/qtquickcontrols2_git.bb:do_package_qa

qemux86 (7)

   * sources/meta-browser/recipes-browser/chromium/chromium-x11_75.0.3770.90.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/android-tools/android-tools_5.1.1.r37.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-devtools/breakpad/breakpad_git.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-multimedia/alsa/alsa-oss_1.1.8.bb:do_compile
   * sources/meta-openembedded/meta-oe/recipes-support/vboxguestdrivers/vboxguestdrivers_5.2.22.bb:do_compile
   * sources/meta-qt5/recipes-qt/qt5/qt5-creator_git.bb:do_compile
   * sources/meta-rust/recipes-devtools/rust/libstd-rs_1.34.2.bb:do_compile

qemux86_64 (0)

Number of failed tasks (39)

qemuarm 12 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm.20190618_213721.log/
qemuarm64 13 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemuarm64.20190619_114514.log/
qemux86 11 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86.20190618_213711.log/
qemux86_64 3 http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.world.qemux86-64.20190619_092706.log/

PNBLACKLISTs (2)

QA issues (2)

Count Issue
0 already-stripped
0 build-deps
0 compile-host-path
0 file-rdeps
0 installed-vs-shipped
0 invalid-pkgconfig
0 ldflags
0 libdir
0 pkgname
0 qa_pseudo
0 symlink-to-sysroot
0 unknown-configure-option
0 version-going-backwards
1 host-user-contaminated
1 textrel


Incorrect PACKAGE_ARCH or sstate signatures (0)

Complete log: http://logs.nslu2-linux.org/buildlogs/oe/world/warrior/log.signatures.20190620_024235.log/


   * ERROR: Nothing RPROVIDES 'bigbuckbunny-480p' (but /home/jenkins/oe/world/yoe/sources/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb RDEPENDS on or otherwise requires it)
   * ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
   * ERROR: no sigdata files were generated for MACHINE qemux86copy in /home/jenkins/oe/world/yoe/build/tmpfs/stamps
   * ERROR: Nothing RPROVIDES 'bigbuckbunny-480p' (but /home/jenkins/oe/world/yoe/sources/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb RDEPENDS on or otherwise requires it)
   * ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
   * ERROR: no sigdata files were generated for MACHINE qemux86 in /home/jenkins/oe/world/yoe/build/tmpfs/stamps
   * ERROR: Nothing RPROVIDES 'bigbuckbunny-720p' (but /home/jenkins/oe/world/yoe/sources/meta-openembedded/meta-multimedia/recipes-multimedia/packagegroups/packagegroup-meta-multimedia.bb RDEPENDS on or otherwise requires it)
   * ERROR: Required build target 'meta-world-pkgdata' has no buildable providers.
   * ERROR: no sigdata files were generated for MACHINE qemuarm in /home/jenkins/oe/world/yoe/build/tmpfs/stamps


PNBLACKLISTs: sources/meta-96boards: sources/meta-atmel: sources/meta-browser: sources/meta-freescale: sources/meta-freescale-3rdparty: sources/meta-intel: sources/meta-odroid: sources/meta-openembedded: meta-oe/recipes-devtools/librcf/librcf_2.2.0.0.bb:PNBLACKLIST[librcf] = " error: invalid use of incomplete type 'RCF::AsioIoService {aka class boost::asio::io_service}; among others?" sources/meta-qcom: sources/meta-qt5: sources/meta-raspberrypi: sources/meta-riscv: sources/meta-rust: sources/meta-ti: sources/meta-variscite-fslc: sources/meta-yoe: sources/openembedded-core: meta/lib/oeqa/selftest/cases/imagefeatures.py:PNBLACKLIST[busybox] = "Don't build this" PNBLACKLIST[android-system] = "depends on lxc from meta-virtualiazation which isn't included in my world builds" PNBLACKLIST[bigbuckbunny-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-480p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[bigbuckbunny-720p] = "big and doesn't really need to be tested so much" PNBLACKLIST[tearsofsteel-1080p] = "big and doesn't really need to be tested so much" PNBLACKLIST[build-appliance-image] = "tries to include whole downloads directory in /home/builder/poky :/" PNBLACKLIST[smartrefrigerator] = "Needs porting to QT > 5.6" PNBLACKLIST[qmlbrowser] = "Needs porting to QT > 5.6" PNBLACKLIST[minehunt] = "Needs porting to QT > 5.6" PNBLACKLIST[homeautomation] = "Needs porting to QT > 5.6" PNBLACKLIST[samegame] = "Needs porting to QT > 5.6" PNBLACKLIST[applicationlauncher] = "Needs porting to QT > 5.6"


QA issues by type: count: 0 issue: already-stripped


count: 0 issue: libdir


count: 1 issue: textrel mpeg2dec-0.5.1: ELF binary '/tmp/work/armv7vet2hf-neon-yoe-linux-gnueabi/mpeg2dec/0.5.1-r0/packages-split/libmpeg2/usr/lib/libmpeg2.so.0.1.0' has relocations in .text [textrel]


count: 0 issue: build-deps


count: 0 issue: file-rdeps


count: 0 issue: version-going-backwards


count: 1 issue: host-user-contaminated qtquickcontrols2-5.12.3+gitAUTOINC+f7ba074ca1: qtquickcontrols2: /qtquickcontrols2-qmlplugins/usr/lib/qml/QtQuick/Controls.2/Fusion/TabBar.qml is owned by uid 3004, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]


count: 0 issue: installed-vs-shipped


count: 0 issue: unknown-configure-option


count: 0 issue: symlink-to-sysroot


count: 0 issue: invalid-pkgconfig


count: 0 issue: pkgname


count: 0 issue: ldflags


count: 0 issue: compile-host-path


count: 0 issue: qa_pseudo