[bitbake-devel] [PATCH v2] command.py: multiconfig support for findBestProvider

Bystricky, Juro juro.bystricky at intel.com
Mon Apr 10 15:41:06 UTC 2017


I concur, it is more readable and I think it merits v3.
V3 coming momentarily.

Juro

________________________________________
From: Patrick Ohly [patrick.ohly at intel.com]
Sent: Sunday, April 09, 2017 11:01 PM
To: Bystricky, Juro
Cc: bitbake-devel at lists.openembedded.org; richard.purdie at linuxfoundation.org
Subject: Re: [PATCH v2] command.py: multiconfig support for findBestProvider


> +def split_mc_pn(pn):
> +    if pn.startswith("multiconfig:"):
> +        mc = pn.split(":")[1]
> +        pn = ":".join(pn.split(":")[2:])

I find this more readable:

if pn.startswith("multiconfig:"):
    _, mc, pn = pn.split(":", 2)

Not sure whether it is worth a v3, though.

--
Best Regards, Patrick Ohly

The content of this message is my personal opinion only and although
I am an employee of Intel, the statements I make here in no way
represent Intel's position on the issue, nor am I authorized to speak
on behalf of Intel on this matter.






More information about the bitbake-devel mailing list