<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Sep 3, 2015 at 7:20 AM, Richard Purdie <span dir="ltr"><<a href="mailto:richard.purdie@linuxfoundation.org" target="_blank">richard.purdie@linuxfoundation.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div id=":1rf" class="a3s" style="overflow:hidden">- self.event_handle = bb.event.register_UIHhandler(s)<br>
+ self.event_handle = bb.event.register_UIHhandler(s, True)</div></blockquote></div><br>Minor quibble: when using positional arguments of this sort, directly, without an intermediate variable, when reading it, it's not clear what the argument is doing. Admittedly, we do this all the time with getVar(), but really that was a crappy API to begin with :) The code becomes a bit more readable if you pass the argument name as though it was a keyword argument, so we have context when reading it, e.g.:</div><div class="gmail_extra"><br></div><div class="gmail_extra"> self.event_handle = bb.event.register_UIHhandler(s, mainui=True)</div><div class="gmail_extra"><br></div><div class="gmail_extra">Obviously, this is relatively minor, so shouldn't block a merge, but it's something to keep in mind going forward.</div><div class="gmail_extra">-- <br><div class="gmail_signature">Christopher Larson<br>clarson at kergoth dot com<br>Founder - BitBake, OpenEmbedded, OpenZaurus<br>Maintainer - Tslib<br>Senior Software Engineer, Mentor Graphics</div>
</div></div>