<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On 19 January 2017 at 16:13, Trevor Woerner <span dir="ltr"><<a href="mailto:twoerner@gmail.com" target="_blank">twoerner@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex"><div id="gmail-:4o2" class="gmail-a3s gmail-aXjCH gmail-m159b78324580453e">Is there not already a mechanism for generically saying "I need <this> task of<br>
<that> recipe to be completed before my <such-and-such> task can run" of which<br>
DEPENDS and RDEPENDS are simply short-hand notations?<br>
<br>
If "yes" (and I understand the discussion correctly) couldn't that be employed<br>
here?<br>
<br>
If "no" (and I understand the discussion correctly) wouldn't adding such a<br>
mechanism be a possible solution. The use of which, hopefully, would make it<br>
easier for a user to understand what's going on (without requiring ad-hoc<br>
knowledge of the system)?</div></blockquote></div><br>Yes, there is. do_some_task[depends] += "some-recipe:some_other_task".</div><div class="gmail_extra"><br></div><div class="gmail_extra">DEPENDS is just a neat way of setting [depends] on do_configure to the list of recipes in DEPENDS's do_populate_sysroot task.</div><div class="gmail_extra"><br></div><div class="gmail_extra">The problem is that do_package_write doesn't exist: the task is do_package_write_deb ..._ipk and ..._rpm. Thus the single variable that the classes and recipes write to, and the package classes do:</div><div class="gmail_extra"><br></div><div class="gmail_extra"><span style="font-size:12.800000190734863px">do_package_write_rpm[depends] += "${PACKAGE_WRITE_DEPS}"</span><br style="font-size:12.800000190734863px"></div><div class="gmail_extra"><span style="font-size:12.800000190734863px"><br></span></div><div class="gmail_extra"><span style="font-size:12.800000190734863px">Simples! :)</span></div><div class="gmail_extra"><span style="font-size:12.800000190734863px"><br></span></div><div class="gmail_extra"><span style="font-size:12.800000190734863px">IMHO, the current name is fine. As the dependencies are added to do_package_write, it's the most obvious name.</span></div><div class="gmail_extra"><span style="font-size:12.800000190734863px"><br></span></div><div class="gmail_extra"><span style="font-size:12.800000190734863px">Ross</span></div></div>