[oe-commits] Jeremy Lainé : bitbake.conf, lib_package.bbclass: fix packaging of ${base_libdir}/*.so

GIT User account git at amethyst.openembedded.net
Mon Apr 20 09:46:51 UTC 2009


Module: openembedded.git
Branch: org.openembedded.dev
Commit: ba434bd1dc9dc8ed61953a1579ea9e993e81cbb2
URL:    http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ba434bd1dc9dc8ed61953a1579ea9e993e81cbb2

Author: Jeremy Lainé <jeremy.laine at m4x.org>
Date:   Mon Apr 20 11:42:08 2009 +0200

bitbake.conf, lib_package.bbclass: fix packaging of ${base_libdir}/*.so

We need to include ${base_libdir}/*${SOLIBSDEV} in FILES_${PN]}  because
the shared libraries in ${base_libdir} do not follow the usual *.so.* naming
convention, for instance libproc-3.2.7.so.

---

 classes/lib_package.bbclass |    6 +++++-
 conf/bitbake.conf           |    7 ++++++-
 2 files changed, 11 insertions(+), 2 deletions(-)

diff --git a/classes/lib_package.bbclass b/classes/lib_package.bbclass
index 03ba9d0..f866d10 100644
--- a/classes/lib_package.bbclass
+++ b/classes/lib_package.bbclass
@@ -1,8 +1,12 @@
 PACKAGES += "${PN}-bin"
 
+# NB: ${base_libdir}/*${SOLIBSDEV} is included here because the shared libraries
+# in ${base_libdir} do not follow the usual *.so.* naming convention, for instance
+# libproc-3.2.7.so
 FILES_${PN} = "${libexecdir} ${libdir}/lib*${SOLIBS} \
 	    ${sysconfdir} ${sharedstatedir} ${localstatedir} \
-	    ${base_libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}"
+	    ${base_libdir}/*${SOLIBS} ${base_libdir}/*{SOLIBSDEV} \
+	    ${datadir}/${PN} ${libdir}/${PN}"
 FILES_${PN}-dev = "${includedir} ${libdir}/lib*${SOLIBSDEV} ${libdir}/*.la \
 		${libdir}/*.a ${libdir}/pkgconfig /lib/*.a /lib/*.o \
 		${datadir}/aclocal ${bindir}/*-config"
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index 30ee0ae..41e9c05 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -211,9 +211,14 @@ PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev ${PN}-locale"
 PACKAGES_DYNAMIC = "${PN}-locale-*"
 FILES = ""
 
+# NB: ${base_libdir}/*${SOLIBSDEV} is included here because the shared libraries
+# in ${base_libdir} do not follow the usual *.so.* naming convention, for instance
+# libproc-3.2.7.so
 FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
             ${sysconfdir} ${sharedstatedir} ${localstatedir} \
-            ${base_bindir}/* ${base_sbindir}/* ${base_libdir}/*${SOLIBS} ${datadir}/${PN} ${libdir}/${PN}/* \
+            ${base_bindir}/* ${base_sbindir}/* \
+            ${base_libdir}/*${SOLIBS} ${base_libdir}/*{SOLIBSDEV} \
+            ${datadir}/${PN} ${libdir}/${PN}/* \
             ${datadir}/pixmaps ${datadir}/applications \
             ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
             ${libdir}/bonobo/servers"





More information about the Openembedded-commits mailing list