[oe-commits] Chris Larson : base.bbclass: rename base_eventhandler to build_summary

git version control git at git.openembedded.org
Mon Nov 8 15:08:05 UTC 2010


Module: openembedded.git
Branch: darwin
Commit: 72a44c7959d94d769939968a681f2c9f29f5b715
URL:    http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=72a44c7959d94d769939968a681f2c9f29f5b715

Author: Chris Larson <chris_larson at mentor.com>
Date:   Tue Nov  2 18:24:57 2010 -0700

base.bbclass: rename base_eventhandler to build_summary

This better reflects what the event handler is doing -- it's no longer a pile
of random base event handling bits, it now just displays a build summary at
build start.

Signed-off-by: Chris Larson <chris_larson at mentor.com>

---

 classes/base.bbclass |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/classes/base.bbclass b/classes/base.bbclass
index a14354d..308498f 100644
--- a/classes/base.bbclass
+++ b/classes/base.bbclass
@@ -232,8 +232,7 @@ python base_do_unpack() {
             oe_unpack(d, local, urldata)
 }
 
-addhandler base_eventhandler
-python base_eventhandler() {
+python build_summary() {
 	from bb import note, error, data
 	from bb.event import getName
 
@@ -253,6 +252,7 @@ python base_eventhandler() {
 		if pesteruser:
 			bb.fatal('The following variable(s) were not set: %s\nPlease set them directly, or choose a MACHINE or DISTRO that sets them.' % ', '.join(pesteruser))
 }
+addhandler build_summary
 
 addtask configure after do_unpack do_patch
 do_configure[dirs] = "${S} ${B}"





More information about the Openembedded-commits mailing list