[OE-core] libzypp variable expansion problem

Kumar Gala galak at kernel.crashing.org
Thu Jul 28 02:19:15 UTC 2011


In meta/recipes-extended/libzypp/libzypp_git.bb we having something that looks like:

        while [ $# -gt 0 ]; do
		...
                if [ "${AVOID_CONSTRUCTOR}" != "true" ]; then
                  ARCH="_$1"
                else
                  ARCH="IdString(\"$1\")"
                fi
		...
                COMPAT_WITH="${ARCH},${COMPAT} $COMPAT_WITH"
        done

The problem is the COMPAT_WITH line should show up in the resulting script as is, however its not getting expanded because ARCH is set.  So we end up with:

	COMPAT_WITH="powerpc,${COMPAT} $COMPAT_WITH"

instead of

	COMPAT_WITH="${ARCH},${COMPAT} $COMPAT_WITH"

Not quite sure how to fix this w/regards to quoting to prevent the expansion.  One solution is to just rename ARCH to something like CARCH.

- k



More information about the Openembedded-core mailing list