[OE-core] [PATCH 6/6] insane.bbclass: Make ldd exec_prefix error reporting easier to read

Mark Hatle mark.hatle at windriver.com
Wed Jun 6 14:53:17 UTC 2012


Remove the long obtuse sysroot path from the ldd output, making the error
message significantly easier to read and understand.

Signed-off-by: Mark Hatle <mark.hatle at windriver.com>
---
 meta/classes/insane.bbclass |    9 ++++++++-
 1 files changed, 8 insertions(+), 1 deletions(-)

diff --git a/meta/classes/insane.bbclass b/meta/classes/insane.bbclass
index 4d139e8..e845250 100644
--- a/meta/classes/insane.bbclass
+++ b/meta/classes/insane.bbclass
@@ -251,7 +251,14 @@ def package_qa_check_unsafe_references_in_binaries(path, name, d, elf, messages)
 			return False
 
 		if sysroot_path_usr in ldd_output:
-			error_msg = pn + ": %s links to something under exec_prefix" % path
+			ldd_output = ldd_output.replace(sysroot_path, "")
+
+			pkgdest = d.getVar('PKGDEST', True)
+			packages = d.getVar('PACKAGES', True)
+
+			short_path = path.replace('%s/%s' % (pkgdest, packages), "", 1)
+
+			error_msg = pn + ": %s links to something under exec_prefix (%s)" % (short_path, exec_prefix)
 			package_qa_handle_error("unsafe-references-in-binaries", error_msg, d)
 			error_msg = "ldd reports: %s" % ldd_output
 			package_qa_handle_error("unsafe-references-in-binaries", error_msg, d)
-- 
1.7.3.4





More information about the Openembedded-core mailing list