[OE-core] some simple questions about assignment and appending

Paul Eggleton paul.eggleton at linux.intel.com
Tue Jun 19 17:32:40 UTC 2012


On Tuesday 19 June 2012 12:28:22 Robert P. J. Day wrote:
>   i want to make absolutely sure i understand the mechanics of the
> different types of assignment so i'm looking at this snippet from
> core-image.bbclass:
> 
> ... snip ...
> 
> PACKAGE_GROUP_qt4-pkgs = "task-core-qt-demos"
> 
> CORE_IMAGE_BASE_INSTALL = '\
>     task-core-boot \
>     task-base-extended \
>     \
>     ${CORE_IMAGE_EXTRA_INSTALL} \
>     '
> 
> CORE_IMAGE_EXTRA_INSTALL ?= ""
> 
> IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
> 
> ... snip ...
> 
>   first, if you're assigning a fixed string (as in the first line
> shown in the snippet above), i assume there is no functional
> difference in using "=" versus ":=", correct?

Correct. := means immediately expand all variable references and set the 
variable's value to the result; if there aren't any references the value is 
the same.

>   next, is there any value in that null line in the assignment to
> CORE_IMAGE_BASE_INSTALL?

There's no functional meaning at least, I assume it is there purely for 
formatting reasons.

>   next, is it technically necessary to conditionally do this?
> 
> CORE_IMAGE_EXTRA_INSTALL ?= ""
> 
> if that variable wasn't set, does it really need to be set to the
> empty string?

Yes - references to unset variables are left unexpanded so without that line 
if the variable was unset you would end up with a literal 
${CORE_IMAGE_EXTRA_INSTALL} within the expanded value of 
CORE_IMAGE_BASE_INSTALL, which would not be good.

>   finally, what are the evaluation mechanics of the "?=" operator?  

?= is the same as = except that it only sets the value if it is not already 
set at the time the line is parsed.

> in this line,
> 
> IMAGE_INSTALL ?= "${CORE_IMAGE_BASE_INSTALL}"
> 
> is the right-hand side evaluated first?  i ask since i find the
> snippet above a bit confusing in that you need to follow backwards to
> deduce what IMAGE_INSTALL is eventually set to.  i would think this
> would be easier to read:
> 
> CORE_IMAGE_BASE_INSTALL = '\
>     task-core-boot \
>     task-base-extended
> 
> IMAGE_INSTALL = "${CORE_IMAGE_BASE_INSTALL} ${CORE_IMAGE_EXTRA_INSTALL}"
> 
>   in this rewriting, i can *immediately* see what values are used to
> construct IMAGE_INSTALL.  in the current code, it's nowhere near as
> clear, and you have to backtrack to see how CORE_IMAGE_BASE_INSTALL is
> assigned.

So overall I agree this has unfortunately ended up being rather messy. To me, 
the above change should be OK at face value and would improve readability; 
however given that we potentially broke people's images/configuration not that 
long ago by changing from POKY_* to CORE_IMAGE_* I think we want to be careful 
about making significant changes to this again.

Cheers,
Paul

-- 

Paul Eggleton
Intel Open Source Technology Centre




More information about the Openembedded-core mailing list