[OE-core] [RFC][PATCH 0/7] image creation improvements

Ed Bartosh ed.bartosh at linux.intel.com
Fri May 6 14:58:43 UTC 2016


Hi,

This patchset contains various improvements for the image creation functionality
made by Patchick Ohly during his work on bug #9076:
 - added support for zip compression
 - fixed dependency calculation for conversion chaining
 - converted vmdk/vdi/qcow2 image types into conversion commands
 - renamed COMPRESSION variables to CONVERSION as the term "compression"
   is no longer accurate
 - prioritized specialized image creation methods over using conversion chaining

The changes look reasonable to me. However, it would be good to hear other
people opinions as some changes are quite complex.

The following changes since commit 912e372bd3097b1475df2689f9aec88dd3198976:

  scripts/lib/bsp/kernel.py: force patching when branch is machine branch is re-use (2016-05-06 10:32:24 +0100)

are available in the git repository at:

  git://git.yoctoproject.org/poky-contrib ed/oe-core/image-type-9076
  http://git.yoctoproject.org/cgit.cgi/poky-contrib/log/?h=ed/oe-core/image-type-9076

Patrick Ohly (7):
  image_types: add support for zip compression
  image.bbclass: support duplicate compression types
  image.bbclass: fix dependency calculation when using conversion
    chaining
  image.bbclass: additional output in create_symlinks
  image creation: support converting masked types
  image.bbclass: rename COMPRESS(ION) to CONVERSION
  image.bbclass: prefer specialized image creation methods over chaining

 meta/classes/image-live.bbclass                    |   2 +-
 meta/classes/image-vm.bbclass                      |  31 +---
 meta/classes/image.bbclass                         | 186 +++++++++++++++------
 meta/classes/image_types.bbclass                   | 104 ++++++------
 meta/classes/image_types_uboot.bbclass             |  18 +-
 meta/conf/documentation.conf                       |   1 -
 .../images/build-appliance-image_14.0.0.bb         |   6 +-
 7 files changed, 204 insertions(+), 144 deletions(-)

-- 
Regards,
Ed



More information about the Openembedded-core mailing list