[OE-core] [PATCH 0/6] deployed artifacts naming improvements

Martin Jansa martin.jansa at gmail.com
Sun Aug 19 22:15:07 UTC 2018


This is just the preparation for last bigger change to have consistent
naming across all deployed artifacts. These 6 preparation commits
shouldn't change any names yet, verified with core-image-base for
qemux86 and raspberrypi3.

Using more variables allows to simplify appending some release
information to the images, corresponding kernels and other artifacts as
shown in:
https://github.com/webOS-ports/meta-webos-ports/commit/6fd0af4dbd3da396d41e330f9dd932e859c5f7f0

The recipes and classes which generate or use new artifacts might need
to inherit kernel-artifact-names and update the variables as shown in
example here:
https://github.com/shr-distribution/meta-smartphone/commit/5e70b3779e0d6c90fbfbafeca2c9e4c4943d1196

The final change which allows to re-use do_deploy from sstate, while
still producing the consistent naming scheme (e.g. image as well as
kernel will have the same DATETIME stamp or for release the same build
number even when the kernel.do_deploy was used for multiple builds will
look like this:
http://git.openembedded.org/openembedded-core-contrib/commit/?h=jansa/master&id=91e5b30f10f24210c31d3f5ec137de22f89967d7

The following changes since commit 176e50fb177dc40e439700d5f3f838dd7eaaa427:

  runtime selftest: limit kernel hw bp arches (2018-08-16 22:40:06 +0100)

are available in the Git repository at:

  git://git.openembedded.org/openembedded-core-contrib jansa/kernel
  http://cgit.openembedded.org/openembedded-core-contrib/log/?h=jansa/kernel

Martin Jansa (6):
  bitbake.conf, kernel-artifact-names.bbclass: introduce
    IMAGE_VERSION_SUFFIX instead of using DATETIME directly
  kernel-artifact-names, kernel-fitimage: add KERNEL_FIT_BASE_NAME,
    KERNEL_FIT_SYMLINK_NAME variables
  kernel*.bbclass: rename *_SYMLINK_NAME variables to *_LINK_NAME and
    *_BASE_NAME to *_NAME
  kernel-artifact-names.bbclass, kernel.bbclass: remove prefix and
    extension from MODULE_TARBALL_* variables
  kernel-artifact-names.bbclass: Add 2 more variables to make it easier
    to change all names with one variable
  kernel.bbclass: rename type variable to imageType

 meta/classes/kernel-artifact-names.bbclass | 27 +++++-----
 meta/classes/kernel-devicetree.bbclass     | 22 ++++----
 meta/classes/kernel-fitimage.bbclass       | 34 +++++-------
 meta/classes/kernel.bbclass                | 62 +++++++++++-----------
 meta/conf/bitbake.conf                     |  5 +-
 5 files changed, 70 insertions(+), 80 deletions(-)

-- 
2.17.1




More information about the Openembedded-core mailing list