[OE-core] [PATCH 1/2 V2] oe/utils.py: Add vartrue()

Robert Yang liezhi.yang at windriver.com
Wed Sep 5 08:11:58 UTC 2018


Hi Peter,

On 09/05/2018 03:33 PM, Peter Kjellerstedt wrote:
>> -----Original Message-----
>> From: openembedded-core-bounces at lists.openembedded.org <openembedded-
>> core-bounces at lists.openembedded.org> On Behalf Of Robert Yang
>> Sent: den 5 september 2018 09:16
>> To: openembedded-core at lists.openembedded.org
>> Subject: [OE-core] [PATCH 1/2 V2] oe/utils.py: Add vartrue()
>>
>> It can be used to simplify code like:
>> "${@['iffalse', 'iftrue'][var]}"
>>
>> Signed-off-by: Robert Yang <liezhi.yang at windriver.com>
>> ---
>>   meta/conf/bitbake.conf | 2 +-
>>   meta/lib/oe/utils.py   | 7 +++++++
>>   2 files changed, 8 insertions(+), 1 deletion(-)
>>
>> diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
>> index faef771..dbadeb3 100644
>> --- a/meta/conf/bitbake.conf
>> +++ b/meta/conf/bitbake.conf
>> @@ -610,7 +610,7 @@ DEBUG_FLAGS ?= "-g -feliminate-unused-debug-types
>> ${DEBUG_PREFIX_MAP}"
>>   # Disabled until the option works properly -feliminate-dwarf2-dups
>>   FULL_OPTIMIZATION = "-O2 -pipe ${DEBUG_FLAGS}"
>>   DEBUG_OPTIMIZATION = "-O -fno-omit-frame-pointer ${DEBUG_FLAGS} -pipe"
>> -SELECTED_OPTIMIZATION = "${@d.getVar(['FULL_OPTIMIZATION',
>> 'DEBUG_OPTIMIZATION'][d.getVar('DEBUG_BUILD') == '1'])}"
>> +SELECTED_OPTIMIZATION = "${@d.getVar(oe.utils.vartrue('DEBUG_BUILD',
>> 'DEBUG_OPTIMIZATION', 'FULL_OPTIMIZATION', d))}"
>>   SELECTED_OPTIMIZATION[vardeps] += "FULL_OPTIMIZATION
>> DEBUG_OPTIMIZATION"
>>   BUILD_OPTIMIZATION = "-O2 -pipe"
>>
>> diff --git a/meta/lib/oe/utils.py b/meta/lib/oe/utils.py
>> index f22a6ab..914a6f2 100644
>> --- a/meta/lib/oe/utils.py
>> +++ b/meta/lib/oe/utils.py
>> @@ -464,3 +464,10 @@ class ImageQAFailed(bb.build.FuncFailed):
>>               msg = msg + ' (%s)' % self.description
>>
>>           return msg
>> +
>> +def vartrue(var, iftrue, iffalse, d):
>> +    import oe.types
>> +    if oe.types.boolean(d.getVar(var)):
>> +        return iftrue
>> +    else:
>> +        return iffalse
> 
> Put it together with ifelse() and conditional() instead, where it better
> belongs.
> 
> You can also implement it as:
> 
> def vartrue(var, iftrue, iffalse, d):
>      import oe.types
>      return oe.utils.ifelse(oe.types.boolean(d.getVar(var), iftrue, iffalse):

Then we need import oe.utils, and I don't think that it's easier to read
than:

+
+def vartrue(var, iftrue, iffalse, d):
+    import oe.types
+    if oe.types.boolean(d.getVar(var)):
+        return iftrue
+    else:
+        return iffalse

// Robert

> 
>> --
>> 2.7.4
> 
> //Peter
> 
> 



More information about the Openembedded-core mailing list