<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Tue, Feb 5, 2013 at 1:42 AM, ChenQi <span dir="ltr"><<a href="mailto:Qi.Chen@windriver.com" target="_blank">Qi.Chen@windriver.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div bgcolor="#FFFFFF" text="#000000"><div><div class="h5">
<div>On 02/02/2013 03:08 AM, Bruce Ashfield
wrote:<br>
</div>
<blockquote type="cite">
<div dir="ltr"><br>
<div class="gmail_extra"><br>
<br>
<div class="gmail_quote">On Fri, Feb 1, 2013 at 1:56 PM, Saul
Wold <span dir="ltr"><<a href="mailto:sgw@linux.intel.com" target="_blank">sgw@linux.intel.com</a>></span>
wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div>On 02/01/2013 06:18 AM, Bruce Ashfield
wrote:<br>
</div>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div>
<br>
<br>
<br>
On Fri, Feb 1, 2013 at 4:00 AM, <<a href="mailto:Qi.Chen@windriver.com" target="_blank">Qi.Chen@windriver.com</a><br>
</div>
<mailto:<a href="mailto:Qi.Chen@windriver.com" target="_blank">Qi.Chen@windriver.com</a>>>
wrote:<br>
<br>
From: Chen Qi <<a href="mailto:Qi.Chen@windriver.com" target="_blank">Qi.Chen@windriver.com</a>
<mailto:<a href="mailto:Qi.Chen@windriver.com" target="_blank">Qi.Chen@windriver.com</a>>>
<div>
<br>
<br>
Add config fragments to busybox.<br>
<br>
Both the implementation and the use case are
similar to yocto kernel's<br>
configuration fragments.<br>
<br>
<br>
I can fairly easily tweak the configuration parts of
the kern-tools to<br>
handle this<br>
use case as well. That would allow us to re-use the
kernel's merge_config.sh<br>
script (with a minor dependency change) and save some
duplicated code. It<br>
also gets you the advantage that you can consolidate
configuration fragments<br>
outside of any build system, which isn't as critical
here, but something<br>
that<br>
is used quite a bit during kernel testing.<br>
<br>
</div>
</blockquote>
Bruce,<br>
<br>
Where is the merge_config.sh script today? Would you
propose moving it to the scripts dir and have the busybox
recipe call it?<br>
</blockquote>
<div><br>
</div>
<div>It's part of the mainline kernel, hence why
grabbing the guts out of it reproducing </div>
<div>it here isn't the best idea, we'll have a need
to keep them in sync. In fact, I have</div>
<div>2 or 3 pending patches for it in the
kern-tools repository that I need to get upstream</div>
<div>
(as an example).</div>
<div><br>
</div>
<div>I'd propose either creating a separate recipe
for it (i.e. like kconfig-frontends) or I could</div>
<div>keep it in kern-tools (badly named, but we can
work on that ;) and maintain / coordinate</div>
<div>changes to it.</div>
<div><br>
</div>
<div>I just don't want to see the effort happen
twice, we are busy enough!</div>
<div> </div>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
What would be your timing on making such a change, ie hold
this patch until your get it merge or merge this and then
fix it when you merge your changes?<br>
</blockquote>
<div><br>
</div>
<div>I could feasibly get it done in the next few
weeks, the changes aren't bug, I just</div>
<div>have to avoid regressions on either side
(kernel or busy box). </div>
<div><br>
</div>
<div>That being said, the interface to the SRC_URI
is the same for the two, so if we are</div>
<div>ok with me arriving and removing the in-recipe
support, I guess I can't object too</div>
<div>much :) The only risk is that if anyone starts
using this first support immediately, </div>
<div>I do risk regressing their use case, where if
it never goes in, that won't happen.</div>
<div><br>
</div>
<div>Cheers,</div>
<div><br>
</div>
<div>Bruce</div>
<div><br>
</div>
<br>
</div>
</div>
</div>
</blockquote>
<br></div></div>
Hi Bruce,<br>
<br>
I just tried to reuse the kernel's merge_config.sh script, and it
turned out well.<br>
The patch is in attachment.<br>
<br>
Is it enough for now?<br></div></blockquote><div><br></div><div style>Yep, this is enough for now. It re-uses the significant part of the infrastructure, which</div><div style>is the important part. Once it is in tree, I can refine the dependency and some other</div>
<div style>minor modifications.</div><div style><br></div><div style>Feel free to add my Signed-off-by: to the patch as well.</div><div style><br></div><div style>Cheers,</div><div style><br></div><div style>Bruce</div><div>
</div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div bgcolor="#FFFFFF" text="#000000">
If so, I'll send out the patch.<br>
<br>
Thanks,<br>
Chen Qi<br>
</div>
</blockquote></div><br><br clear="all"><div><br></div>-- <br>"Thou shalt not follow the NULL pointer, for chaos and madness await thee at its end"
</div></div>