<div dir="ltr"><br><div class="gmail_extra"><br><br><div class="gmail_quote">On Fri, Jan 3, 2014 at 3:26 PM, Paul Eggleton <span dir="ltr"><<a href="mailto:paul.eggleton@linux.intel.com" target="_blank">paul.eggleton@linux.intel.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="HOEnZb"><div class="h5">On Friday 03 January 2014 13:25:13 Andrei Gherzan wrote:<br>
> On Sun, Dec 29, 2013 at 04:44:52PM +0100, Koen Kooi wrote:<br>
> > -----BEGIN PGP SIGNED MESSAGE-----<br>
> > Hash: SHA1<br>
> ><br>
> > Philip Balister schreef op 28-12-13 23:33:<br>
> > > On 12/28/2013 10:28 AM, Koen Kooi wrote:<br>
> > >> Paul Eggleton schreef op 28-12-13 12:48:<br>
> > >>> Hi Koen,<br>
> > >>><br>
> > >>> On Tuesday 24 December 2013 15:22:32 Koen Kooi wrote:<br>
> > >>>> Burton, Ross schreef op 23-12-13 19:01:<br>
> > >>>>> We'd like to integrate Piglit (an OpenGL test suite) into Poky<br>
> > >>>>> so that we can run automated QA on the GL stack. Piglit is<br>
> > >>>>> currently residing in meta-oe, but as Poky is a self-contained<br>
> > >>>>> project we can't just add meta-oe to it: apart from the size of<br>
> > >>>>> meta-oe, we can't ensure stability if meta-oe makes incompatible<br>
> > >>>>> changes that affect Poky.<br>
> > >>>>><br>
> > >>>>> Piglit isn't a stand-alone package, there are the dependencies<br>
> > >>>>> of waffle, python-mako and python-numpy to consider too. There<br>
> > >>>>> are two possibilities I can see:<br>
> > >>>>><br>
> > >>>>> 1) Move piglit and deps to oe-core. Piglit is for QA purposes<br>
> > >>>>> only and pushes the boundaries of "core platform". In a sense<br>
> > >>>>> this is a repeat of the discussion we had with Midori... does<br>
> > >>>>> oe-core contain everything needed to sufficiently exercise the<br>
> > >>>>> core components it ships or not?<br>
> > >>>>><br>
> > >>>>> 2) Add piglit and deps to meta-yocto. Probably a new layer<br>
> > >>>>> called meta-yocto-qa (or similar) because the Yocto Compatible<br>
> > >>>>> guidelines forbid mixing distribution policy and recipes.<br>
> > >>>><br>
> > >>>> Speaking of layers, can you *please* rename meta-yocto to<br>
> > >>>> meta-poky? It's what it's actually is and would remove a lot of<br>
> > >>>> confusion when trying to explain that yocto is not a distro, even<br>
> > >>>> if the distro layer is called 'meta-yocto'.<br>
> > >>><br>
> > >>> This is a tangent, but a couple of points:<br>
> > >>><br>
> > >>> 1) This rename would not come for free. We'd need to update people's<br>
> > >>> existing bblayers.conf files on the fly, as we did when<br>
> > >>> meta-yocto-bsp was split out of meta-yocto, and thus bump<br>
> > >>> LCONF_VERSION; however, doing this only in poky has resulted in<br>
> > >>> annoying problems when users remove poky from their configurations<br>
> > >>> (since LCONF_VERSION is out-of-step between Poky and OE-Core, leading<br>
> > >>> to confusing errors in this situation). Thus I think we'd want to<br>
> > >>> solve this once and for all by bumping the value in OE-Core as well<br>
> > >>> as Poky.<br>
> > >>><br>
> > >>> 2) If you propose this rename, perhaps you will also consider<br>
> > >>> renaming meta-oe, since that name within a similarly named<br>
> > >>> meta-openembedded repository leads to a similar level of<br>
> > >>> confusion...?<br>
> > >><br>
> > >> I have no problems with renaming that layer since I get confused by<br>
> > >> this a few times a week myself :)<br>
> > ><br>
> > > What would we we rename it to?<br>
> ><br>
> > I'm very tempted to suggest 'meta-yocto'<br>
><br>
> I definitely find meta-yocto a better option here. It would save me from<br>
> some confusion when talking about yocto to other people.<br>
<br>
</div></div>I'm not following; meta-yocto is already called meta-yocto ... ? Maybe you<br>
didn't realise Koen was joking...<br>
<div class="im"><br></div></blockquote><div><br></div><div>Misread that. I thought he was talking about poky. Taking back my stupid statement.</div><div><br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im">
> Related to meta-oe, even if that would be a smaller problem, I think<br>
> meta-openembedded is a better name for that layer too.<br>
<br>
</div>That doesn't solve the problem I was talking about, namely that there's little<br>
distinction between meta-openembedded the repository (that contains a number<br>
of layers) and meta-oe which is one of those layers. These are two different<br>
things and the similar naming makes it hard to always know which one people<br>
are talking about.</blockquote><div><br></div><div>In that case the collection of layers should be meta-openembedded and the meta-oe layer something like meta-openembedded-common or whatever. </div><div><br></div></div>-- </div>
<div class="gmail_extra"><b style="color:rgb(51,51,51);font-family:Arial;text-align:center">ag</b>
</div></div>