<div dir="ltr"><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Jul 22, 2015 at 3:55 AM, Paul Eggleton <span dir="ltr"><<a href="mailto:paul.eggleton@linux.intel.com" target="_blank">paul.eggleton@linux.intel.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div id=":n9" class="a3s" style="overflow:hidden">I must admit it wasn't immediately obvious to me why you'd made some of the<br>
changes here, although after several reads it does make sense - would you be<br>
able to add a slightly more detailed commit message explaining the changes?<br>
(same for the equivalent devtool patch).</div></blockquote></div><br>Will do, thanks.</div><div class="gmail_extra"><br></div><div class="gmail_extra">- The tinfoil setup had to be split, as we need access to the tinfoil object to get BBPATH.</div><div class="gmail_extra">- The argument parsing was split into two, first just the global options, the second for everything else, to let us enable debugging or quiet mode before the plugins are loaded, so we can see details about that process, rather than doing it all at once. —help, while global, shouldn’t be handled in the first pass, otherwise the help info will lack info about the plugins.</div><div class="gmail_extra"><br></div><div class="gmail_extra">I’ll add that info to the commit message, and also rename initial_args to global_args to hopefully clarify it a bit better in the code.<br>-- <br><div class="gmail_signature"><div dir="ltr">Christopher Larson<br>kergoth at gmail dot com<br>Founder - BitBake, OpenEmbedded, OpenZaurus<br>Maintainer - Tslib<br>Senior Software Engineer, Mentor Graphics</div></div>
</div></div>