<html>
<head>
<meta content="text/html; charset=windows-1252"
http-equiv="Content-Type">
</head>
<body text="#000000" bgcolor="#FFFFFF">
<p><br>
</p>
<br>
<div class="moz-cite-prefix">On 11/17/2016 06:14 AM, Burton, Ross
wrote:<br>
</div>
<blockquote
cite="mid:CAJTo0LbxF0sdYqmK3ttUyaiyTPmg+ME9qbSS1NnpcA4H7iQLaQ@mail.gmail.com"
type="cite">
<div dir="ltr">
<div class="gmail_extra"><br>
<div class="gmail_quote">On 16 November 2016 at 00:50,
Francisco Pedraza <span dir="ltr"><<a
moz-do-not-send="true"
href="mailto:francisco.j.pedraza.gonzalez@intel.com"
target="_blank">francisco.j.pedraza.gonzalez@intel.com</a>></span>
wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0
.8ex;border-left:1px #ccc solid;padding-left:1ex">
<div id=":619" class="a3s aXjCH m1586aa8e9d4ce13a">Will
verify the following:<br>
1. Compile a minimal image.<br>
2. The compiled image will add the created layer with
the<br>
recipes postinstz postinsta postinstb postinstd
postinstp postinstt<br>
created previously at "meta-selftest/recipes-test"<br>
2. Run qemu<br>
3. Validate the task execution order.<br>
V4<br>
</div>
</blockquote>
<div><br>
</div>
<div>This is missing the test that some postinsts should be
happening at rootfs time.</div>
</div>
</div>
</div>
</blockquote>
I have assigned the bug 8433 and I will send a different patch to
add those test cases, I'm just waiting to the final implementation
of this patch to be accepted to avoid execution and merge
conflicts. <br>
<blockquote
cite="mid:CAJTo0LbxF0sdYqmK3ttUyaiyTPmg+ME9qbSS1NnpcA4H7iQLaQ@mail.gmail.com"
type="cite">
<div dir="ltr">
<div class="gmail_extra">
<div class="gmail_quote">
<div><br>
</div>
<div>Also, can it permute PACKAGE_CLASSES (rotate through
all three options) so it exercises all backends.</div>
<div><br>
</div>
<blockquote class="gmail_quote" style="margin:0 0 0
.8ex;border-left:1px #ccc solid;padding-left:1ex">
<div id=":619" class="a3s aXjCH m1586aa8e9d4ce13a">
Signed-off-by: Francisco Pedraza <<a
moz-do-not-send="true"
href="mailto:francisco.j.pedraza.gonzalez@intel.com">francisco.j.pedraza.gonzalez@<wbr>intel.com</a>><br>
---<br>
.../recipes-test/postinsta/<a moz-do-not-send="true"
href="http://postinsta_1.0.bb" rel="noreferrer"
target="_blank">pos<wbr>tinsta_1.0.bb</a> | 20
+++++++++++<br>
.../recipes-test/postinstb/<a moz-do-not-send="true"
href="http://postinstb_1.0.bb" rel="noreferrer"
target="_blank">pos<wbr>tinstb_1.0.bb</a> | 22
++++++++++++<br>
.../recipes-test/postinstd/<a moz-do-not-send="true"
href="http://postinstd_1.0.bb" rel="noreferrer"
target="_blank">pos<wbr>tinstd_1.0.bb</a> | 22
++++++++++++<br>
.../recipes-test/postinstp/<a moz-do-not-send="true"
href="http://postinstp_1.0.bb" rel="noreferrer"
target="_blank">pos<wbr>tinstp_1.0.bb</a> | 22
++++++++++++<br>
.../recipes-test/postinstt/<a moz-do-not-send="true"
href="http://postinstt_1.0.bb" rel="noreferrer"
target="_blank">pos<wbr>tinstt_1.0.bb</a> | 22
++++++++++++<br>
.../recipes-test/postinstz/<a moz-do-not-send="true"
href="http://postinstz_1.0.bb" rel="noreferrer"
target="_blank">pos<wbr>tinstz_1.0.bb</a> | 12
+++++++</div>
</blockquote>
</div>
<br>
For clarity can all of these be squashed into a single recipe
with clearer names?</div>
<div class="gmail_extra"><br>
</div>
<div class="gmail_extra">Ross</div>
</div>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset>
<br>
</blockquote>
<br>
</body>
</html>