<div dir="ltr">Is that *right* though? Non-arch libdir is for architecture-independent pieces as the name suggests.<div><br></div><div>Ross</div></div><div class="gmail_extra"><br><div class="gmail_quote">On 9 May 2018 at 16:49, Dan McGregor <span dir="ltr"><<a href="mailto:danismostlikely@gmail.com" target="_blank">danismostlikely@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">From: Dan McGregor <<a href="mailto:dan.mcgregor@usask.ca">dan.mcgregor@usask.ca</a>><br>
<br>
Setting staging_libdir to libdir caused unnecessary rebuilds of<br>
go-native when switching from a multilib build to a non-multilib<br>
build. Switch to nonarch_libdir because that's the same on both<br>
multilib and regular builds.<br>
<br>
Signed-off-by: Dan McGregor <<a href="mailto:dan.mcgregor@usask.ca">dan.mcgregor@usask.ca</a>><br>
---<br>
meta/recipes-devtools/go/go-<wbr>native.inc | 2 +-<br>
1 file changed, 1 insertion(+), 1 deletion(-)<br>
<br>
diff --git a/meta/recipes-devtools/go/go-<wbr>native.inc b/meta/recipes-devtools/go/go-<wbr>native.inc<br>
index b76fb0825e4..76c83848cd3 100644<br>
--- a/meta/recipes-devtools/go/go-<wbr>native.inc<br>
+++ b/meta/recipes-devtools/go/go-<wbr>native.inc<br>
@@ -1,6 +1,6 @@<br>
# Use immediate assingment here to get the original (/usr/lib)<br>
# instead of the one rewritten by native.bbclass.<br>
-nonstaging_libdir := "${libdir}"<br>
+nonstaging_libdir := "${nonarch_libdir}"<br>
<br>
inherit native<br>
<span class="HOEnZb"><font color="#888888"> <br>
-- <br>
2.18.0-dev<br>
<br>
-- <br>
______________________________<wbr>_________________<br>
Openembedded-core mailing list<br>
<a href="mailto:Openembedded-core@lists.openembedded.org">Openembedded-core@lists.<wbr>openembedded.org</a><br>
<a href="http://lists.openembedded.org/mailman/listinfo/openembedded-core" rel="noreferrer" target="_blank">http://lists.openembedded.org/<wbr>mailman/listinfo/openembedded-<wbr>core</a><br>
</font></span></blockquote></div><br></div>