<div dir="ltr"><br><br><div class="gmail_quote"><div dir="ltr">On Fri, Jun 22, 2018 at 8:10 AM Christopher Larson <<a href="mailto:kergoth@gmail.com">kergoth@gmail.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><br><br><div class="gmail_quote"><div dir="ltr">On Fri, Jun 22, 2018 at 12:42 AM Richard Purdie <<a href="mailto:richard.purdie@linuxfoundation.org" target="_blank">richard.purdie@linuxfoundation.org</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">On Fri, 2018-06-22 at 02:08 +0500, Christopher Larson wrote:<br>
> From: Christopher Larson <<a href="mailto:chris_larson@mentor.com" target="_blank">chris_larson@mentor.com</a>><br>
> <br>
> This class sets POSTINST_INTERCEPTS and<br>
> POSTINST_INTERCEPTS_CHECKSUMS,<br>
> to allow us to pull intercepts from BBPATH. This is kept as a<br>
> separate<br>
> class, as it's needed by both image construction and sdk<br>
> construction,<br>
> the latter to support meta-toolchain & similar recipes.<br>
> <br>
> Signed-off-by: Christopher Larson <<a href="mailto:chris_larson@mentor.com" target="_blank">chris_larson@mentor.com</a>><br>
> ---<br>
> meta/classes/bbpath-intercepts.bbclass | 23 +++++++++++++++++++++++<br>
> 1 file changed, 23 insertions(+)<br>
> create mode 100644 meta/classes/bbpath-intercepts.bbclass<br>
<br>
We're struggling a bit with classes and namespaces. I'm wondering if<br>
this might be better as "image-postinst-intercepts.bbclass" or similar.<br>
That would mean the variable namespace matches the class and that the<br>
image classes are more 'together'.<br>
<br>
Your next patch will need rebasing against the changes that just merged<br>
into master in image.bbclass.<br>
<br>
I have also wondered about pushing more code to lib/oe but I can see<br>
why this makes sense as a bbclass.<br></blockquote><div><br></div><div class="">Yeah, I think in this case this works as a class, but you're right, we should probably shift more to the python package. Namespacing is probably a good idea, we've talked about doing that more in the past. In this case it's technically not image-only, though an sdk uses the same underlying functionality, so it's debatable. I wonder if we should namespace into a subdirectory to also make it easier to make sense of classes/ at a command-line, i.e. inherit image/postinst-intercepts.bbclass? Hmmm.</div></div></div></blockquote><div><br></div><div>I'll submit a v2 rebased with the class renamed as you suggested for now, later today. Thanks.<br></div></div>-- <br><div dir="ltr" class="gmail_signature" data-smartmail="gmail_signature"><div dir="ltr"><div><div dir="ltr">Christopher Larson<br>kergoth at gmail dot com<br>Founder - BitBake, OpenEmbedded, OpenZaurus<br>Senior Software Engineer, Mentor Graphics</div></div></div></div></div>