[oe] [RFC] Enable --hash-style=both for all recent gcc4 targets

Koen Kooi k.kooi at student.utwente.nl
Wed Oct 15 08:51:33 UTC 2008


On 15-10-2008 10:22, Holger Freyther wrote:
> Hey guys,
>
> I would start linking everything with -Wl,--hash-style=both as this is said to
> speed up the loading of shared libraries by about 50%

Also check the as-needed stuff from Poky:

ASNEEDED = "-Wl,--as-needed"
ASNEEDED_pn-console-tools = ""
ASNEEDED_pn-distcc = ""
ASNEEDED_pn-openobex = ""
ASNEEDED_pn-icu = ""
ASNEEDED_pn-xserver-kdrive-xomap = ""
ASNEEDED_pn-minimo = ""
ASNEEDED_pn-pciutils = ""
ASNEEDED_pn-puzzles = ""
ASNEEDED_pn-dialer = ""

TARGET_LDFLAGS += "${ASNEEDED}"

That should also reduce library load time *and* eliminate spurious deps.

> (google is your
> friend). This is an option for binutils and was introduced with binutils
> 2.17. Now there are two ways to achieve this:
>
> Change TARGET_LDFLAGS in e.g. the distro config (as this knows if binutils has
> this option available) or to change the "specs" of gcc to enable this by
> default. There is a patch from debian for gcc4.3 but it is leaving
> arm/armeabi out. What do you guys prefer?

It seems that the TARGET_LDFLAGS in distro would be the best option forward.

> I'm pretty sure that we will want to use the GNU hash style at Openmoko and
> this is creating an interesting problem in regard to a full system upgrade
> (which is supposed to work). Again there are two ways. Use force and bump PE
> on each package but we should avoid this.

PE is only there to fix versioning screwups (be it upstream or OE)

> I propose to rename PR to FILE_PR
> and change PR  to "${FILE_PR}${DISTRO_PR}" so everytime a distro is changing
> something that effects every package we can bump (e.g. Setting DISTRO_PR
> to .1 for Openmoko).

That sounds like a good idea, it would make changing compiler versions a 
lot safer.

regards,

Koen





More information about the Openembedded-devel mailing list