[oe] [PATCH 3/3] linux-openmoko: rename recipes to common PN_PV scheme and adjust om-gta* machine configs

Martin Jansa martin.jansa at gmail.com
Wed May 26 12:20:58 UTC 2010


On Tue, May 25, 2010 at 4:37 PM, Khem Raj <raj.khem at gmail.com> wrote:
> On (25/05/10 15:30), Martin Jansa wrote:
>> * unify preferred provider and version for om-gta02
>>
>> Signed-off-by: Martin Jansa <Martin.Jansa at gmail.com>
>
> Acked-by: Khem Raj <raj.khem at gmail.com>
>
>> ---
>>  conf/distro/openmoko.conf                          |    8 -
>>  conf/machine/om-3d7k.conf                          |    3 +-
>>  conf/machine/om-gta01.conf                         |   12 +--
>>  conf/machine/om-gta02.conf                         |   10 +-
>>  recipes/linux/linux-openmoko-2.6.24_git.bb         |   28 ----
>>  recipes/linux/linux-openmoko-2.6.28_git.bb         |   28 ----
>>  .../0007-Enable-UBI-UBIFS.patch                    |  149 ++++++++++++++++++++
>>  .../linux/linux-openmoko-2.6.29/fix-install.patch  |   23 +++
>>  recipes/linux/linux-openmoko-2.6.32_git.bb         |   46 ------
>>  recipes/linux/linux-openmoko-2.6.34_git.bb         |   39 -----
>>  .../0007-Enable-UBI-UBIFS.patch                    |  149 --------------------
>>  .../linux-openmoko-shr-devel/fix-install.patch     |   23 ---
>>  recipes/linux/linux-openmoko-shr-devel_git.bb      |   26 ----
>>  recipes/linux/linux-openmoko_2.6.24.bb             |   28 ++++
>>  recipes/linux/linux-openmoko_2.6.28.bb             |   28 ++++
>>  recipes/linux/linux-openmoko_2.6.29.bb             |   26 ++++
>>  recipes/linux/linux-openmoko_2.6.32.bb             |   46 ++++++
>>  recipes/linux/linux-openmoko_2.6.34_git            |   39 +++++
>>  18 files changed, 347 insertions(+), 364 deletions(-)
>>  delete mode 100644 recipes/linux/linux-openmoko-2.6.24_git.bb
>>  delete mode 100644 recipes/linux/linux-openmoko-2.6.28_git.bb
>>  create mode 100644 recipes/linux/linux-openmoko-2.6.29/0007-Enable-UBI-UBIFS.patch
>>  create mode 100644 recipes/linux/linux-openmoko-2.6.29/fix-install.patch
>>  delete mode 100644 recipes/linux/linux-openmoko-2.6.32_git.bb
>>  delete mode 100644 recipes/linux/linux-openmoko-2.6.34_git.bb
>>  delete mode 100644 recipes/linux/linux-openmoko-shr-devel/0007-Enable-UBI-UBIFS.patch
>>  delete mode 100644 recipes/linux/linux-openmoko-shr-devel/fix-install.patch
>>  delete mode 100644 recipes/linux/linux-openmoko-shr-devel_git.bb
>>  create mode 100644 recipes/linux/linux-openmoko_2.6.24.bb
>>  create mode 100644 recipes/linux/linux-openmoko_2.6.28.bb
>>  create mode 100644 recipes/linux/linux-openmoko_2.6.29.bb
>>  create mode 100644 recipes/linux/linux-openmoko_2.6.32.bb
>>  create mode 100644 recipes/linux/linux-openmoko_2.6.34_git

Too late I found flaw of this (or in how SRCPV works) :/.

As long as those were recipes from same GIT repo but with different PN
it was ok, because in persistent cache they got different keys:

sqlite> select * from BB_URI_LOCALCOUNT where key like '%linux-openmoko%';
git:git.openmoko.org.git.kernel.git-linux-openmoko-shr-devel_rev|973a41fce60e5f6edfcf0eaf94056a57eee65e16
git:git.openmoko.org.git.kernel.git-linux-openmoko-shr-devel_count|1
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.32_rev|a9254be10ac2294ea20165a87c09ea6afcf66d94
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.32_count|0
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.31_rev|dd32737aa524e09c1d141a0e735dd58674552244
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.31_count|0
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.28_rev|8c65792a5c83c76d662a617a7c4e1ae8104bb6a5
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.28_count|0
git:git.openmoko.org.git.kernel.git-linux-openmoko-shr-drm-devel_rev|e62a4ae1c6783f41b41a9ac3d258786586b65a40
git:git.openmoko.org.git.kernel.git-linux-openmoko-shr-drm-devel_count|0
git:git.openmoko.org.git.kernel.git-linux-openmoko-devel_rev|a15608f241a40b41fed5bffe511355c2067c4e88
git:git.openmoko.org.git.kernel.git-linux-openmoko-devel_count|0
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.24_rev|fb42ce6724576fc173faf8abfb04aa2c36d213b7
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.24_count|0
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.34_rev|dd1225cc08c3375bf80289ac1965c724881b149a
git:git.openmoko.org.git.kernel.git-linux-openmoko-2.6.34_count|1

now they all use
'git:git.openmoko.org.git.kernel.git-linux-openmoko_rev' and each
recipe parsing seems to increase _count by number of
linux-openmoko*.bb recipes (because _rev is changed between each
recipe) :/.

git:git.openmoko.org.git.kernel.git-linux-openmoko_rev|dd1225cc08c3375bf80289ac1965c724881b149a
git:git.openmoko.org.git.kernel.git-linux-openmoko_count|78

Please advise what should be best fix for this. I'm OK with reverting
my last 2 commits and keeping unique PN for them, but maybe the same
issue can be found in other recipes too.

Using recipe name for persistent cache could be easy solution but
needs updated bitbake :/.

Regards,




More information about the Openembedded-devel mailing list