[oe] [PATCH 4/4] gitpkgv.bbclass: rename git_drop_tag_prefix to fix conflict

Andreas Oberritter obi at opendreambox.org
Fri Feb 11 12:51:43 UTC 2011


* fixes ERROR: Error Method already seen: git_drop_tag_prefix in
  'gitver.bbclass' now in 'gitpkgv.bbclass'

Signed-off-by: Andreas Oberritter <obi at opendreambox.org>
CC: Otavio Salvador <otavio at ossystems.com.br>
---
 classes/gitpkgv.bbclass |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/classes/gitpkgv.bbclass b/classes/gitpkgv.bbclass
index d4b8287..bedceb9 100644
--- a/classes/gitpkgv.bbclass
+++ b/classes/gitpkgv.bbclass
@@ -40,7 +40,7 @@
 GITPKGV = "${@get_git_pkgv(d, False)}"
 GITPKGVTAG = "${@get_git_pkgv(d, True)}"
 
-def git_drop_tag_prefix(version):
+def gitpkgv_drop_tag_prefix(version):
     import re
     if re.match("v\d", version):
         return version[1:]
@@ -71,7 +71,7 @@ def get_git_pkgv(d, use_tags):
 
 			if use_tags:
 				try:
-					ver = git_drop_tag_prefix(bb.fetch.runfetchcmd("git describe %s 2>/dev/null" % rev, d, quiet=True).strip())
+					ver = gitpkgv_drop_tag_prefix(bb.fetch.runfetchcmd("git describe %s 2>/dev/null" % rev, d, quiet=True).strip())
 				except Exception:
 					ver = "0.0-%s-g%s" % (commits, rev[:7])
 			else:
-- 
1.7.2.3





More information about the Openembedded-devel mailing list