[oe] [PATCH 5/6] Added images for the TS7500 ARM SBCs

Marcin Juszkiewicz marcin at juszkiewicz.com.pl
Wed Mar 30 14:33:25 UTC 2011


Dnia 2011-03-30, śro o godzinie 10:07 -0400, UDel V2G Team pisze:
> * This commit includes two images - one for building the initrd image and the other for
>   building the rootfs image.
> 
> Signed-off-by: UDel V2G Team <v2g.udel at gmail.com>

Please use real "name surname" instead.

> diff --git a/recipes/images/ts75xx-initrd-image.bb b/recipes/images/ts75xx-initrd-image.bb
> new file mode 100644
> index 0000000..306bf3a
> --- /dev/null
> +++ b/recipes/images/ts75xx-initrd-image.bb

> +# Use a newer version of busybox since it includes the nbd-client applet.
> +# We no longer need to build the nbd-client program since we enable this.
> +DEPENDS = "busybox-1.18.3"

This is ugly - please provide patch which will enable nbd-client in
default busybox instead.

> +IMAGE_INSTALL = "busybox 

> canctl dioctl dmxctl spictl ts-utils ts-initrd \

I suggest creating task-ts75xx for it. Will be easier to add them into
images.

> +# This should build all the correct device tables.
> +IMAGE_DEVICE_TABLES = "files/device_table-ts75xx.txt"

This should probably be set in machine config. What if I will build this
image for c7x0?

> +fix_image () {

s/fix_image/remove_any_files_we_do_not_want_in_initrd/

Some will be done by setting package management variable to "none".


> +++ b/recipes/images/ts75xx-rootfs-image.bb

> +IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp ; "

> +IMAGE_INIT_MANAGER = "sysvinit"

> +DISTRO_SSH_DAEMON = "openssh"

Do not override this - this is *distro* decision does it want openssh or
dropbear.

> +DEPENDS = "\
> +	task-proper-tools \
> +	${DISTRO_SSH_DAEMON} \
> +	${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
> +	${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
> +	canctl dioctl dmxctl spictl ts-utils ts-initrd \

> +	coreutils \
> +	findutils \
> +	bash \

Those are part of task-proper-tools iirc.

> +	python \

without extra modules?

> +KERNEL_MODULES = "\

why not install "kernel-modules" meta package instead?





More information about the Openembedded-devel mailing list