[oe] [RFC][PATCH v2] plowshare: Add Git version (initial recipe)

Matthieu mcrapet at gmail.com
Tue Aug 14 12:50:16 UTC 2012


Add recipe for plowshare (git repository).

v2:
- fix big mistake DEPENDS => RDEPENDS
- set SRCREV to empty string
- keep PE=1 to respect upstream scheme

Signed-off-by: Matthieu Crapet <mcrapet at gmail.com>
---
 meta/recipes-support/plowshare/plowshare_git.bb |   27
+++++++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 meta/recipes-support/plowshare/plowshare_git.bb

diff --git a/meta/recipes-support/plowshare/plowshare_git.bbb/meta/recipes-support/plowshare/
plowshare_git.bb
new file mode 100644
index 0000000..f819255
--- /dev/null
+++ b/meta/recipes-support/plowshare/plowshare_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Command-line download/upload tool for file sharing hosters"
+HOMEPAGE = "http://code.google.com/p/plowshare/"
+SECTION = "console/utils"
+
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+# Follow uptream (debian) naming convention,
+# for example: plowshare_1~git20120807-1_all.deb
+PV = "gitr${SRCPV}"
+PE = "1"
+SRCREV = ""
+
+RDEPENDS_${PN} = "bash curl"
+SRC_URI = "git://
code.google.com/p/plowshare.git;protocol=http;branch=master"
+S = "${WORKDIR}/git"
+
+inherit allarch
+
+# Nothing to compile, it's scripts!
+do_compile() {
+ :
+}
+
+do_install() {
+ oe_runmake PREFIX="${prefix}" DESTDIR="${D}" install
+}
--
1.7.9.5



More information about the Openembedded-devel mailing list