[oe] [meta-oe][PATCH] pam-plugin-ldapdb: add recipe

Andre McCurdy armccurdy at gmail.com
Wed May 23 00:51:12 UTC 2018


On Tue, May 22, 2018 at 4:10 AM, Richard Leitner
<richard.leitner at skidata.com> wrote:
> Add recipe for version 1.3 of pam-plugin-ldapdb, a PAM module for
> directly binding a user DN to an LDAP server.
>
> Signed-off-by: Richard Leitner <richard.leitner at skidata.com>
> ---
>  .../recipes-extended/pam/pam-plugin-ldapdb_1.3.bb  | 23 ++++++++++++++++++++++
>  1 file changed, 23 insertions(+)
>  create mode 100644 meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb
>
> diff --git a/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb b/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb
> new file mode 100644
> index 000000000..a68d1999f
> --- /dev/null
> +++ b/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb
> @@ -0,0 +1,23 @@
> +SUMMARY = "PAM searchless LDAP authentication module"
> +HOMEPAGE = "https://github.com/rmbreak/pam_ldapdb"
> +BUGTRACKER = "https://github.com/rmbreak/pam_ldapdb/issues"
> +SECTION = "libs"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=41ab94182d94be9bb35e2a8b933f1e7d"
> +
> +DEPENDS += "libpam openldap"

The usual convention is to assign to DEPENDS with = rather than +=

> +inherit distro_features_check
> +REQUIRED_DISTRO_FEATURES = "pam"
> +
> +SRC_URI = "https://github.com/rmbreak/pam_ldapdb/archive/v${PV}.tar.gz"

To give the local file a meaningful file name, you can have bitbake
rename it as part of the download process by adding
";downloadfilename=${BP}.tar.gz" to the end of SRC_URI.

Note however that there have recently been a series of patches merged
to meta-oe which updated recipes to build from git clones rather than
github tar file archives, so you may want to consider doing that in
this recipe too.

> +SRC_URI[md5sum] = "2dd4f1370fcfe995ee0ad09611109b87"
> +SRC_URI[sha256sum] = "8ed92b36523556bb5d9bf3eb33a1035e46041d4be767c8d62136930c0ca0e45b"
> +
> +S = "${WORKDIR}/pam_ldapdb-${PV}"
> +
> +do_install () {
> +    oe_runmake install DESTDIR=${D} PAMDIR=${base_libdir}/security
> +}
> +
> +FILES_${PN} = "${base_libdir}/security/pam_ldapdb.so"

It's conventional to add to the default packaging rules rather than
over-ride them, ie use += here rather than =



More information about the Openembedded-devel mailing list