[oe] sanitize.py

cyril Romain c.romain at laposte.net
Mon Sep 11 22:19:25 UTC 2006


Another try for the attachment: the script itself this time.

cyril Romain wrote:
> Hi Jamie,
>
> Jamie Lenehan wrote:
>> Nice work on sanitize.py, I like it!
>>
>> Here's a few things I'd like to see changed:
>>
>> * For initscripts the order should be:
>>
>>   INITSCRIPT_PACKAGES
>>   INITSCRIPT_NAME
>>   INITSCRIPT_PARAMS
>>
>> since the PACKAGES lists which packages we are going to have
>> initscripts for while the NAME and PARAMS are repeated for each one
>> of those packages, like this:
>>
>>   # Main init script starts all deamons
>>   # Seperate init script for watchquagga
>>   INITSCRIPT_PACKAGES                     = "${PN} ${PN}-watchquagga"
>>   INITSCRIPT_NAME_${PN}                   = "quagga"
>>   INITSCRIPT_PARAMS_${PN}                 = "defaults 15 85"
>>   INITSCRIPT_NAME_${PN}-watchquagga       = "watchquagga"
>>   INITSCRIPT_PARAMS_${PN}-watchquagga     = "defaults 90 10"
>>
>>   
> Corrected!
>> Also it seems to split these up when they probably should be kept
>> together. ie, the above currently comes out as this:
>>
>>   INITSCRIPT_NAME_${PN}                   = "quagga"
>>   INITSCRIPT_NAME_${PN}-watchquagga       = "watchquagga"
>>
>>   # Main init script starts all deamons
>>   # Seperate init script for watchquagga
>>   INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga"
>>
>>   INITSCRIPT_PARAMS_${PN}                 = "defaults 15 85"
>>   INITSCRIPT_PARAMS_${PN}-watchquagga     = "defaults 90 10"
>>
>>
>>   
> Corrected!
>> * For alternatives the order should be:
>>
>>   ALTERNATIVE_NAME
>>   ALTERNATIVE_PATH
>>   ALTERNATIVE_LINK
>>   ALTERNATIVE_PRIORITY
>>
>> since NAME and PATH are required while LINK and PRIORITY are
>> optional. I think it's better to always have the two required entries
>> first and then the optional ones, like this:
>>
>>   ALTERNATIVE_NAME = "awk"
>>   ALTERNATIVE_PATH = "gawk"
>>   ALTERNATIVE_LINK = "${bindir}/awk"
>>   ALTERNATIVE_PRIORITY = "100"
>>
>>   
> Corrected!
>> It also splits these up and they should probably be kept together as
>> well. ie, the above currently comes out as this:
>>
>>   ALTERNATIVE_LINK = "${bindir}/awk"
>>
>>   ALTERNATIVE_NAME = "awk"
>>
>>   ALTERNATIVE_PATH = "gawk"
>>
>>   ALTERNATIVE_PRIORITY = "100"
>>
>>
>>   
> Corrected!
>> * It doesn't know about the PKG variable (the name of the package,
>>   used to prevent debian.bbclass from changing the name to an
>>   internal shared library name.):
>>
>>   ## Warning: unknown variable/routine "PKG_${PN}-ospfd         = 
>> ${PN}-ospfd"
>>   ## Warning: unknown variable/routine "PKG_${PN}-ospfclient    = 
>> ${PN}-ospfclient"
>>
>>   
> PKG key added!
>> * It doesn't know about pre/post rm/install scripts (maybe it's not
>>   meant to?):
>>
>>   ## Warning: unknown variable/routine "pkg_prerm_${PN} () {"
>>   ## Warning: unknown variable/routine "        
>> ${sysconfdir}/init.d/quagga stop"
>>   ## Warning: unknown variable/routine "}"
>>   ## Warning: unknown variable/routine "pkg_prerm_${PN}-ospfd () {"
>>   ## Warning: unknown variable/routine "        
>> ${sysconfdir}/init.d/quagga stop ospfd"
>>   ## Warning: unknown variable/routine "}"
>>
>>   
> Corrected! (pkg pre rm/install were missing)
>
> In attachment the new version of sanitize.py. Among the above 
> corrections, it handles more cases so it is less buggy for sure.
> I send it to you as a patch. Can anyone please commit the patch ? 
> (sorry to ask but I don't have right to commit)
>
> Thank you for pointing that out :-)
>
> Best regards,
>
>  Cyril
> ------------------------------------------------------------------------
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel at lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel
>   



More information about the Openembedded-devel mailing list